Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 16 of 16

    Thread: Symptoms of bad spark plugs.....

    1. 10-30-2001 12:47 PM #1
      ok I think i need some new spark plugs, wires, cap and rotor. What are some symptoms(sp?) of this....right now what happening is sometimes when the revs pass 5k the car sputters.....and sometimes when i down shift and floor it the car with act like it almost stalls...then backfires and then just keeps going.....i just replaced the ECU is there anything else i should check??

    2. 10-30-2001 01:24 PM #2
      I know my plugs are bad when my car is really sluggish in accelleration, and I can smell raw gas.

      This happens after about 5-6 bottles of NOS, so I went with the Iridium plusg, and have not had a problem since.


    3. 10-30-2001 01:43 PM #3
      well i dont have n2o but what brand plugs are you using?

    4. 10-30-2001 03:03 PM #4
      Well if you're running Bosch Platinum +4's then thats your answer.

    5. 10-30-2001 03:36 PM #5
      nope i wasnt....but i just replaced the plugs, wires, cap and rotor and the for the first time since i had it m car started right up....tomarrow im gonna drive the piss out of it to see if it fixed the other problems......either way i now have wires that are under a lifetime warrenty

    6. Senior Member VW1990CORRADO's Avatar
      Join Date
      Sep 30th, 2000
      Location
      Billerica,MA/autoengineering.com
      Posts
      20,405
      Vehicles
      3 cars, 3 turbos
      10-30-2001 04:33 PM #6
      you need to run the factory plugs on a g60. 15bux a plug but you CAN rev past 5k with em........wp6d or something? get em.
      -Rick- .:HBC Strive for excellence
      NOW mine2002 Gti 337 PTE5857B,2008 Ibis Audi A4 Ti hers2010 Tiguan SEL
      THEN 2001 S4 90 corrado,90 gti vr6, 95 golf sport+many,many more..
      www.autoengineering.com

    7. 10-30-2001 04:45 PM #7
      car has been running with champion plugs so thats what i put in and it reved to 6500 just fine......the car likes the new stuff i put in a lot....

    8. Senior Member VW1990CORRADO's Avatar
      Join Date
      Sep 30th, 2000
      Location
      Billerica,MA/autoengineering.com
      Posts
      20,405
      Vehicles
      3 cars, 3 turbos
      10-30-2001 04:57 PM #8
      champion? arent those for lawnmowers??? get the stock ones and you will be straight. also get a new fuel filter too. under 20 bux.
      -Rick- .:HBC Strive for excellence
      NOW mine2002 Gti 337 PTE5857B,2008 Ibis Audi A4 Ti hers2010 Tiguan SEL
      THEN 2001 S4 90 corrado,90 gti vr6, 95 golf sport+many,many more..
      www.autoengineering.com

    9. 10-30-2001 06:27 PM #9
      hmm...fuel filter....

      these plugs are working just fine...if they start acting up ill get some stock ones


    10. 10-30-2001 06:51 PM #10
      [QUOTE]champion? arent those for lawnmowers??? [QUOTE]

      Bwaaaaaaaaa ha ha ha ha ha ha ha ha ha ha

      Now that was a good one, I have not heard of champion sparkplugs forever...Do they still make them?


    11. 10-30-2001 06:54 PM #11
      I guess so there are 4 of them in my trunk and 4 running in the car right now....

    12. Senior Member VW1990CORRADO's Avatar
      Join Date
      Sep 30th, 2000
      Location
      Billerica,MA/autoengineering.com
      Posts
      20,405
      Vehicles
      3 cars, 3 turbos
      10-30-2001 10:10 PM #12
      since you probably live near sam i would go seek him for corrado g60 help, he seems to know his ish. he can diagnose it better in person. but i dunno bout those champions though..
      -Rick- .:HBC Strive for excellence
      NOW mine2002 Gti 337 PTE5857B,2008 Ibis Audi A4 Ti hers2010 Tiguan SEL
      THEN 2001 S4 90 corrado,90 gti vr6, 95 golf sport+many,many more..
      www.autoengineering.com

    13. Member SilvBullit's Avatar
      Join Date
      Sep 7th, 2001
      Location
      Portland, Maine
      Posts
      646
      10-30-2001 10:21 PM #13
      Both my girlfriend's and my own G60 will NOT fire all 4 cylinders with the factory Bosch plugs (yes, new). Ever time they foul at least one plug. My car has Neuspeed wires, new cap, rotor, and coil. Hers is all stock. We both run Autolite Platinum and they fired up no matter how cold it is on the first try.

    14. 10-30-2001 10:22 PM #14
      hehe....I talk with sam often.....but danny(jwatts) is just as much(if not more) help and he is closer

      danny told me not to worry about the kind of spark plugs...so i didnt...

      I dont know what I would do without those guys help...and they help of all you vortexers


    15. 11-03-2001 04:37 AM #15
      I too happen to have the champion plugs that iceman has. Happened because Murray's didn't have the dealer only replacement plug and couldn't get them. I had no choice because the stock ones were blacker than my tires. They rev just fine and seem to run just as well. I was told that a long time ago champions were known to become permanantly stuck in the block though. I plan on changing soon just in case that rumor is true. I don't want any champions fused to my block.

    16. 11-03-2001 10:06 AM #16
      most auto places have little packets of grease for that.....

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •