Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 18 of 18

    Thread: turn signal fuse keeps blowing....

    1. 11-26-2004 03:09 PM #1
      i searched and found a boat load of info on turn signal problems, but didn't really see anyone that had problems with the fuse blowing constantly.

      the problems:
      Constant dimly lit turn signal light. when i flip the switch for left or right, has a brighter constant green.
      Hazards work fine and can hear the relay clicking.

      so i'm thinking its not the relay, so its either the hazard switch of the turn signal switch..... anyone else that this problem??


    2. Geriatric Member VDub2625's Avatar
      Join Date
      Jan 3rd, 2003
      Location
      Fall River, MA
      Posts
      46,241
      Vehicles
      90 Jetta GLI 16v, 99.5 Cabrio Highline, 92 Golf GL
      11-26-2004 03:15 PM #2
      Hazard switch. Do the test in the DIY.
      A2Resource
      .......

    3. Banned
      Join Date
      Oct 5th, 2001
      Posts
      3,518
      11-26-2004 03:26 PM #3
      probably grounding out somewherz....

    4. Member mechsoldier's Avatar
      Join Date
      Aug 14th, 2004
      Location
      Seattle, WA
      Posts
      7,477
      Vehicles
      Supercharged 6 spd 98GLX, Choptop 66 Beetle with Porsche 944 brakes and 5 Speed, 13 Sportwagen TDI
      11-26-2004 04:30 PM #4
      Short to ground somewhere before the flasher in the signal circuit
      Dub Autowerks VW, Audi, Porsche, and BMW parts and service
      1723 West Valley Hwy E
      Sumner, WA 98390
      http://www.DubAutowerks.com

    5. 11-26-2004 05:49 PM #5
      thanks for all the info, i really hope is not a short to ground since that could be anywhere.

    6. 11-26-2004 08:30 PM #6
      hi i had a problem with my flashers on my golf and i fixed it but it took me 2 month s to sort it out every time i turned left in the car it would blow a 40 amp fuse

    7. 11-26-2004 08:37 PM #7
      i no this might sound like a funny question but does your handbrake light work

    8. 11-27-2004 12:05 AM #8
      reverse switch! take it out of reverse when you park it, replace fuse then hit turn signal... if it works put it in reverse then try your turn signal... if it doesn't work it's the reverse switch@


      Modified by 88Gl at 8:06 PM 11-26-2004

    9. 11-29-2004 02:20 PM #9
      the reverse lights will work on and off, but the turn signal problem just sprung up one day. with the fuse blowing i dont think its the turn signal switch, maybe a short to ground?? i've been looking for the short but its hopeless.

      powell16v, what'd you do to fix your signal problem??


    10. 11-29-2004 10:43 PM #10
      does it blow the second you put it in?

    11. 12-01-2004 04:03 PM #11
      no, only when i flip the TS switch

      im having a hard time pinpointing the short. next time breaking out the ohm meter


      Modified by RyanBMX at 3:04 PM 12-1-2004


    12. 12-05-2004 06:43 PM #12
      behind the instrument panel my handbrake light light bulb was out of its socket n hangin down on its wires every time i turned left it use to sway to the left nshort out on the dash chassis n blow the fuse sorry it took so long i have bin away so it could be the same case with you so i hope this help s

    13. 12-05-2004 08:49 PM #13
      awesome, i'll give it a check, how the hell did you find it to be that?

    14. 12-06-2004 07:05 PM #14


      nos rules ok


    15. 12-06-2004 07:15 PM #15
      wot you got to remember is at this time was at the end ov my tether so wot we did is take out the fuse and wrap a ship anchor rope round it n we let nature take its course first left corner was like bonfire night threw the center vent

    16. 12-06-2004 08:02 PM #16
      I'm HAVING THE SAME PROBLEM AT THIS VERY MOMENT! LET ME KNOW YOUR SOLUTION. THANKS!

    17. 12-07-2004 01:25 PM #17
      Anyone?

    18. 12-07-2004 08:16 PM #18
      Quote, originally posted by powell16v »
      wot you got to remember is at this time was at the end ov my tether so wot we did is take out the fuse and wrap a ship anchor rope round it n we let nature take its course first left corner was like bonfire night threw the center vent

      what??? oh i get it...the crub and 2 fents did it right??

      i'll keep you posted once i find the solution


    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •