Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Page 226 of 230 FirstFirst ... 126176216222223224225226227228229230 LastLast
    Results 5,626 to 5,650 of 5734

    Thread: High-altitude pulley for NS Supercharger

    1. Member corrado9184's Avatar
      Join Date
      Oct 17th, 2007
      Location
      Texas
      Posts
      570
      Vehicles
      78/79-rabbit 85-Vanagon Westy 86-GTI 86-GLI 91-Corrado 94-Jetta {2}95-Golfs 96-Jetta
      12-23-2011 12:08 PM #5626
      I figured I would join this never ending forum by saying that I picked up a Used Neuspeed charger about two weeks ago. I installed it on my 95 Jetta and am happy with the results. I believe it has a 2.6 inch Pulley since i hit a solid 9psi at redline and almost 4psi right off. The only thing i noticed was an Increased vibration at 4000rpm, not sure if its due to the supercharger or the new engine mounts. When the charger was installed i took a peak at the oil and the charger rotated nicely, but I was in too much of a hurry to enjoy it. I ordered the maintenance kit but it had not come in at the time of the install. My current setup is;


      272 TT cam and valve springs
      Techtonics high flow valves (slightly bigger then stock, have to look up the size again)
      Mild Port and Polish
      Header
      2 1/4 TT Cat back exhaust with magnflow muffler
      Vr6 Cat
      TT adjustable cam gear set at zero.
      Neuspeed Supercharger kit (2.6 pulley i think)
      K&N drop in filter
      Insulated intake gasket from BFI
      BFI .5 motor mounts
      R32 control arm bushings
      80% O2O shim kit
      Neuspeed front and rear sway bars, front strut tower brace and soft sport springs.
      Converted to OBD II (wiring harness issue when I first had the car!!!!)


      Now I just need a better clutch, when i hit 9psi in 3rd,4th and 5th the stock clutch slips! So If any of you know of a good cheap clutch, let me know. Otherwise has anyone else running a 272 cam with this charger? I originally picked it up when the car was running NA with an AEG intake manifold.

    2. 12-24-2011 08:51 AM #5627
      How do you like the .5 mounts? I am looking into picking up a set for my car.

    3. Member corrado9184's Avatar
      Join Date
      Oct 17th, 2007
      Location
      Texas
      Posts
      570
      Vehicles
      78/79-rabbit 85-Vanagon Westy 86-GTI 86-GLI 91-Corrado 94-Jetta {2}95-Golfs 96-Jetta
      12-24-2011 10:31 AM #5628
      I like them so far,i have very little vibration below 4000, above that I get a noticeable vibration. Dont know whats causing it. Maybe the charger, I am not sure but the engine does not jump around like it use to. My wife does not like them or the sport springs.
      Last edited by corrado9184; 12-24-2011 at 10:39 AM.

    4. Member OMGitsKYLE!'s Avatar
      Join Date
      Apr 10th, 2009
      Location
      Boston, Ma
      Posts
      1,746
      Vehicles
      05 PG GLI (sold), 96 Burgundy bagged and blown 2.0 Jetta (Sold) , MKVI Candy White Golf (Daily)
      01-02-2012 01:04 PM #5629
      this has prolly been covered but those of you running the 2.6" pulley did u get a smaller belt too?
      VolkShore Co-Founder

      www.VolkShore.net

      on instagram @krbelch

    5. Member greyhare's Avatar
      Join Date
      Dec 23rd, 2003
      Location
      Corvallis, OR
      Posts
      2,414
      Vehicles
      '96 Jetta, '78 Rabbit, '79 GMC 3/4T 4x4, 2013 BMW F700GS
      01-04-2012 06:33 PM #5630
      I ran the 2.6 on the standard belt without issue.

    6. Member Fast VW's Avatar
      Join Date
      Sep 24th, 2002
      Location
      Central PA
      Posts
      1,652
      Vehicles
      S/C 97 8v 2008 Rabbit
      01-04-2012 11:41 PM #5631
      I ran a 2.4 on the "stock" belt without any issues. The MKIIIs have the advantage of the automatic tensioner. I currently have a shorter belt on but I have noticed no difference.

    7. 01-05-2012 07:10 AM #5632
      How do you like the 2.4" pulley? What other mods do you have with it?

    8. Member Fast VW's Avatar
      Join Date
      Sep 24th, 2002
      Location
      Central PA
      Posts
      1,652
      Vehicles
      S/C 97 8v 2008 Rabbit
      01-05-2012 11:13 PM #5633
      The 2.4 pulley is pretty cool.

      I have:
      1. 2.4 pulley
      2. AT270 cam
      3. Autotech catback SS exhaust (the old single tip design)
      4. C2 motorsports 30# injectors and tune
      5. Stage 3 Snow Performance MAX-MPG water injection kit
      6. Lower temp thermstat and fan switch
      7. Vibratechnics motor mounts

      Here it is:

    9. Member corrado9184's Avatar
      Join Date
      Oct 17th, 2007
      Location
      Texas
      Posts
      570
      Vehicles
      78/79-rabbit 85-Vanagon Westy 86-GTI 86-GLI 91-Corrado 94-Jetta {2}95-Golfs 96-Jetta
      01-23-2012 05:26 PM #5634
      update... I had my supercharger off the other day and measured the pulley and found the size stamped in it. Impossible to see while it was on the car, I have a 2.8 inch stock pulley. So I am looking for a 2.6 or 2.4 inch pulley for a reasonable price.

    10. Member
      Join Date
      Jul 20th, 2001
      Posts
      4,775
      Vehicles
      Fahrvergnügen
      01-29-2012 11:48 PM #5635
      I ran into this thread while surfing the forum, researching a turbo project I'm doing.
      I had a Neuspeed charger several years back. Tons of fun!
      Here's a video that I've kept alive on YouTube:
      http://www.youtube.com/watch?v=WV0LVTfpeTU

    11. Member OMGitsKYLE!'s Avatar
      Join Date
      Apr 10th, 2009
      Location
      Boston, Ma
      Posts
      1,746
      Vehicles
      05 PG GLI (sold), 96 Burgundy bagged and blown 2.0 Jetta (Sold) , MKVI Candy White Golf (Daily)
      05-29-2012 12:55 PM #5636
      any 1 have the pictures from changing the oil on their charger?
      VolkShore Co-Founder

      www.VolkShore.net

      on instagram @krbelch

    12. 05-31-2012 03:32 PM #5637
      pics of the used oil? Or are you after pics of the process?

    13. Member themagellan's Avatar
      Join Date
      Mar 30th, 2007
      Location
      East
      Posts
      2,628
      Vehicles
      1991 Audi 200 20vt Quattro
      08-08-2012 11:37 AM #5638
      Hi All,

      Question about the by-pass valve. What is the best way to test this, and what are some tell tale signs of it no longer working.

      (Background) car suddenly will no longer idle correctly, the valve is fluttering open and idling around 600 rpms. Once you get moving the car will drive relatively OK, however the charger has quit producing any power. I have checked all vacuum lines.

      (Edit for answer) Tensioner failed and valves were consumed.
      Last edited by themagellan; 10-08-2012 at 08:29 PM.

    14. 08-08-2012 12:02 PM #5639
      do you have a boost and/or vacuum gauge on the car?

    15. Member themagellan's Avatar
      Join Date
      Mar 30th, 2007
      Location
      East
      Posts
      2,628
      Vehicles
      1991 Audi 200 20vt Quattro
      08-08-2012 12:14 PM #5640
      Quote Originally Posted by blubayou View Post
      do you have a boost and/or vacuum gauge on the car?
      Not hooked up, if I do hook it up what should I be looking for?

    16. 08-08-2012 01:59 PM #5641
      idling and cruising you shouldn't see boost, only vacuum. When you hit the loud pedal, you should go from vacuum into boost, then back to vacuum when you let off. Before tearing things apart, I'd hook up the gauge (very easy) and see when you do and don't have boost.

      There is a brass orifice inside the nipple on the bypass valve (where the vac line connect from the charger/manifold). This brass orifice has a pretty small opening, which I believe slows/smooths the reaction of the bypass valve. I'd pull that hose off and check to see if something is obstructing that opening. When pulling off the hose, the brass orifice may pull off with it, so check inside the hose for it if it isn't in the bypass valve nipple. If the orifice is blocked, I think you'd be stuck in boost (no recirculation) which may cause issues at idle.

      I'd check on the boost/vac situation, but I wouldn't rule out that you may have some other issue and the bypass valve (i.e vacuum) is fluttering as a result of that.

    17. Member themagellan's Avatar
      Join Date
      Mar 30th, 2007
      Location
      East
      Posts
      2,628
      Vehicles
      1991 Audi 200 20vt Quattro
      08-08-2012 05:09 PM #5642
      Quote Originally Posted by blubayou View Post
      idling and cruising you shouldn't see boost, only vacuum. When you hit the loud pedal, you should go from vacuum into boost, then back to vacuum when you let off. Before tearing things apart, I'd hook up the gauge (very easy) and see when you do and don't have boost.

      There is a brass orifice inside the nipple on the bypass valve (where the vac line connect from the charger/manifold). This brass orifice has a pretty small opening, which I believe slows/smooths the reaction of the bypass valve. I'd pull that hose off and check to see if something is obstructing that opening. When pulling off the hose, the brass orifice may pull off with it, so check inside the hose for it if it isn't in the bypass valve nipple. If the orifice is blocked, I think you'd be stuck in boost (no recirculation) which may cause issues at idle.

      I'd check on the boost/vac situation, but I wouldn't rule out that you may have some other issue and the bypass valve (i.e vacuum) is fluttering as a result of that.
      Looks like I jumped timing and bent some valves... end of that story.
      Last edited by themagellan; 10-08-2012 at 08:28 PM.

    18. Member OMGitsKYLE!'s Avatar
      Join Date
      Apr 10th, 2009
      Location
      Boston, Ma
      Posts
      1,746
      Vehicles
      05 PG GLI (sold), 96 Burgundy bagged and blown 2.0 Jetta (Sold) , MKVI Candy White Golf (Daily)
      09-01-2012 10:25 AM #5643
      anyone have a part number for a belt if i want to bypass the A/C compressor? (with a 2.6" pulley)
      VolkShore Co-Founder

      www.VolkShore.net

      on instagram @krbelch

    19. Member OMGitsKYLE!'s Avatar
      Join Date
      Apr 10th, 2009
      Location
      Boston, Ma
      Posts
      1,746
      Vehicles
      05 PG GLI (sold), 96 Burgundy bagged and blown 2.0 Jetta (Sold) , MKVI Candy White Golf (Daily)
      10-18-2012 11:59 AM #5644
      any1?
      VolkShore Co-Founder

      www.VolkShore.net

      on instagram @krbelch

    20. 10-26-2012 06:33 PM #5645

      These Venom coolers are very interesting. They have listing for the Jackson racing, trd and cobolt superchargers.

    21. 11-28-2012 02:23 PM #5646
      Just got my superC after 5 years, got a few questions will a 4.5 bar fpr work just as good as the 4 bar?

    22. Member SMG8vT's Avatar
      Join Date
      Oct 8th, 2004
      Location
      Nova Scotia
      Posts
      3,311
      Vehicles
      '00 Beetle R32, '66 Beetle Project
      12-01-2012 04:43 PM #5647
      It'll run rich unless the ECM is smart enough to learn and hold back a little bit of fuel but I doubt it.

    23. 12-10-2012 11:50 AM #5648
      I've had the charger for 3 weeks now and everything settled in after a week. Only problem is my maf blew today.... it's all good though. I'm not sure why u guys say this cars so slow, with the super and the mods I've done I'm running 13.5-14 at 70f on an aba obd2, must be that cars don't Cali because mines quick in tx anyway, any clue where I can get a decent maf, I here the vr6 ones more accurate what do you guys think ?

    24. Member VWxghost's Avatar
      Join Date
      Dec 14th, 2009
      Location
      330, OH
      Posts
      8,891
      Vehicles
      1995 Golf GL // 1999.5 Golf 2.0 Supercharged*
      01-09-2013 02:32 PM #5649
      Is it absolutely necessary to run water meth with the 2.4" pulley?
      Euro///Vagens NE Ohio

      8v Society #322

      8 v b o o s t

    25. Member corrado9184's Avatar
      Join Date
      Oct 17th, 2007
      Location
      Texas
      Posts
      570
      Vehicles
      78/79-rabbit 85-Vanagon Westy 86-GTI 86-GLI 91-Corrado 94-Jetta {2}95-Golfs 96-Jetta
      01-21-2013 04:40 PM #5650
      I have been running a 2.5 pulley without water/meth and it seems to be holding together as my daily for a year hitting 12psi. However i am seeing massive timing pulled under boost in the summer and i always run 94 with octane boost. I am also seeing intake temps of 200+ degrees just cruising around town with very short bursts of the lead foot. So its up too you, drive nice, monitor and hope or spend the extra money, take the time to set it up and then have a little peace of mind that your engine might last. I have my water/kit almost fully installed and then i might pick up a 2.4 pulley but not until i am happy with kit.

    Page 226 of 230 FirstFirst ... 126176216222223224225226227228229230 LastLast

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •