Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 8 of 8

    Thread: Plasma Cutter Problems

    1. 12-11-2008 01:46 PM #1
      I just picked up a Snap On YA2230 plasma cutter, knowing that it was not working, but did not know what was wrong. I'm trying to trouble shoot it, and hopefully you guys can guide me on what could be wrong with it.

      It came with no tip or consumables, so I got those from a friend and we tried it. It powers up fine, I hooked up my compressed air and tried it on a piece of aluminum. It cut about 1/16" into the aluminum and gave up. I couldn't get it to arc again after that.

      It's probably 15 or 20 years old. So far I have $0 into it, so if I need to replace some parts, I'll still be WAY ahead.

      Any ideas, or places I should start to research this? Thanks for the help.


    2. Member 65dunebuggy's Avatar
      Join Date
      Jan 22nd, 2008
      Location
      Iowa
      Posts
      1,590
      Vehicles
      12 CW Golf R, FS 06 GTI
      12-11-2008 03:00 PM #2
      Have you used a PC before? but i think your problem is you or the machine is not getting the arc to the work so it stops flow but still has post airflow to cool the tip. But I would try on steel, keeping the tip flat against the work and see if it will arc. The machine should hum if you have arc

    3. 12-11-2008 10:08 PM #3
      I would start with a FULL torch rebuild. There are a few places to buy parts for that. Here's one I just bought some mig supplies from. Very good prices. http://www.htpweld.com/product...n.htm
      I'd also take off a clean all connections. Dig into it

    4. 12-12-2008 10:28 AM #4
      Good find on that site. I will check into buying things from there.

      When I got it, it was missing all of the internal torch pieces, so I replaced them all with brand new pieces A,B and C. D was in good, clean shape, and the holes weren't clogged. I don't have a lot of experience with PCs, but my friend / neighbor does and came over and helped me check it out.

      I'm confident that this rig was abused, since the guy who gave it to me owns a welding shop. So with that assumption, what could go out on it after years of random guys in his shop not using it properly, or touching it to the metal or trying to cut material too thick?

      I'll try it again this weekend on a scrap of steel to see if anything changes. I'll take pictures of the rig too, if you think that'll help.


    5. 12-14-2008 12:41 PM #5
      There is a couple switches inside the torch handle. One for the trigger switch and one behind the head of the torch. They are tiny little switches but if either one is not making contact, the torch will not work. Take apart the handle and try whatever you can think of to clean those, and/or test them if you have the means.

      I'm not 100% certain about your particular torch, but I don't see why it wouldn't be similar with most or all of them.


      Modified by Tjax at 9:42 AM 12-14-2008


    6. 12-14-2008 09:51 PM #6
      You're not going to believe this. I took it all apart and bought the wiring diagram / owner's manual. I ohm'ed out all the connections on the circuit board and they checked out. The problem: Loose connections on this piece. I tightened up all 4 screws, and now it works great!!!

      I was given this plasma cutter because it was "junk" "hasn't worked in a while" and "was going to throw it away, but you can have it if you come get it". HELL YES. Deal of the century.

      And my ghetto plasmic skills!:


    7. 12-14-2008 11:32 PM #7
      YOU LUCKY BASTAGE!!!!!!!!!!

    8. 12-17-2008 10:29 AM #8
      Quote, originally posted by spasticone »
      I'd also take off and clean all connections.

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •