Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 14 of 14

    Thread: Oil Light. Flashing and Sound.

    1. n00b
      Join Date
      Nov 8th, 2010
      Location
      BC, Canada
      Posts
      2
      Vehicles
      1995 VW Golf CL
      11-08-2010 02:07 PM #1
      I have a 1995 Golf cl and when i was driving home the oil light lit up and started to flash and beep. i shifted down into a lower gear and it stopped. when i got home i checked the oil level and it is still full. i drove it this morning and the light never came on. Any ideas on what this could be? thanks

    2. Banned
      Join Date
      Sep 5th, 2010
      Posts
      1,571
      11-08-2010 03:10 PM #2
      Your pump is going out, or the sensor, one or the other. Don't drive it now (important!!!) Replace sensor first, don't drive it far, do a few miles running around your hood, in case it needs to be pushed back. If it does come back on, immediately stop car and cut. Then replace pump.

      Good luck

    3. Member scrambledeggs's Avatar
      Join Date
      Jun 28th, 2010
      Location
      SEPA
      Posts
      1,759
      Vehicles
      '04 24v gti. 2 mk3's sold
      01-01-2011 04:51 PM #3
      mine did the same thing the other day. flashed and beeped twice then went off. today it beeped once and i think the light flashed for half a second
      Quote Originally Posted by MahTrek=] View Post
      Oh and stop saying jolf

    4. Member Sallad's Avatar
      Join Date
      Aug 29th, 2004
      Location
      Kelowna, BC
      Posts
      8,068
      Vehicles
      '94 Jetta 2.0 16v
      01-01-2011 04:53 PM #4
      Do an oil change and switch to a slightly heavier oil. This helped mine.
      Pro Patria

      Making power, 4 valves at a time.
      MkIII 16v Club.

    5. Member scrambledeggs's Avatar
      Join Date
      Jun 28th, 2010
      Location
      SEPA
      Posts
      1,759
      Vehicles
      '04 24v gti. 2 mk3's sold
      01-01-2011 04:57 PM #5
      by the way... oil temp sensor or oil level sensor?
      Quote Originally Posted by MahTrek=] View Post
      Oh and stop saying jolf

    6. Member scrambledeggs's Avatar
      Join Date
      Jun 28th, 2010
      Location
      SEPA
      Posts
      1,759
      Vehicles
      '04 24v gti. 2 mk3's sold
      01-01-2011 05:00 PM #6
      i'm starting to have the same problem. it blinked & beeped at me the other day then same thing today. on GAP, i see the oil temp sensor or oil level sensor so i'm confused
      Quote Originally Posted by MahTrek=] View Post
      Oh and stop saying jolf

    7. Member Greg_J's Avatar
      Join Date
      Oct 30th, 2005
      Location
      Grand Bend ON Canaduh
      Posts
      13,763
      Vehicles
      '03 Wagon TDI 6spd
      01-01-2011 07:42 PM #7
      Quote Originally Posted by rankadoodle View Post
      Your pump is going out, or the sensor, one or the other. Don't drive it now (important!!!) Replace sensor first, don't drive it far, do a few miles running around your hood, in case it needs to be pushed back. If it does come back on, immediately stop car and cut. Then replace pump.

      Good luck

      these are the sensors he's ^^ talking about. replace both. white one is located on the oil filter flange, blue one is located on the drivers side of the head.

      http://www.germanautoparts.com/Volks...ectrical/150/4
      Quote Originally Posted by ennui_delphian View Post
      Don't anger canadiun lesbian...

    8. 01-04-2011 04:19 PM #8
      I have the same problem just got my VW jetta 2.0 1999 old body style, and the light for Oil start flashing and buzzing, after we change the Oil and the oil filter, now I'am about to change the two of the sensors, and will change 10w-30 with 20w-50 ... what I know is if the problems are in the sensor and if you add havier oil and more thick, this lie the sensor, and the light goes off

    9. Member scrambledeggs's Avatar
      Join Date
      Jun 28th, 2010
      Location
      SEPA
      Posts
      1,759
      Vehicles
      '04 24v gti. 2 mk3's sold
      01-15-2011 03:03 AM #9
      Quote Originally Posted by Sallad View Post
      Do an oil change and switch to a slightly heavier oil. This helped mine.
      what oil are you using? 5w30, 10w30, etc?
      i've never had a problem w/ my oil pressure or anything until after my last oil change (which was even a month or two ago and i put in 5w30) and now my light's randomly coming on, flashing and beeping then shutting off. i replaced both switches today then the light was on and beeping for like 30 seconds.
      Last edited by scrambledeggs; 01-15-2011 at 03:09 AM.
      Quote Originally Posted by MahTrek=] View Post
      Oh and stop saying jolf

    10. 01-15-2011 03:54 AM #10
      Drain some oil out of your oil pan and see if there is any metal shavings in there... if not finish draining the oil and check the oil pump for clogs.

    11. Member scrambledeggs's Avatar
      Join Date
      Jun 28th, 2010
      Location
      SEPA
      Posts
      1,759
      Vehicles
      '04 24v gti. 2 mk3's sold
      01-17-2011 06:34 PM #11
      i have a pretty good thread going, called "flashing oil light" or "oil light flashing" i forget which one. check that out
      Quote Originally Posted by MahTrek=] View Post
      Oh and stop saying jolf

    12. Member Sallad's Avatar
      Join Date
      Aug 29th, 2004
      Location
      Kelowna, BC
      Posts
      8,068
      Vehicles
      '94 Jetta 2.0 16v
      01-17-2011 08:52 PM #12
      Quote Originally Posted by scrambledeggs View Post
      what oil are you using? 5w30, 10w30, etc?

      20W50 all year.
      Pro Patria

      Making power, 4 valves at a time.
      MkIII 16v Club.

    13. Banned
      Join Date
      May 15th, 2006
      Location
      PNW
      Posts
      1,025
      Vehicles
      Jettas.. Dodge Cummins, 1985 Trans Am,
      01-17-2011 09:22 PM #13
      Quote Originally Posted by scrambledeggs View Post
      i have a pretty good thread going, called "flashing oil light" or "oil light flashing" i forget which one. check that out
      True..... it's a fun thread... full of insight and idiocy

    14. Banned
      Join Date
      May 15th, 2006
      Location
      PNW
      Posts
      1,025
      Vehicles
      Jettas.. Dodge Cummins, 1985 Trans Am,
      01-17-2011 09:41 PM #14
      If it was beeping, your pressure was below 25 PSI while revs were over 2000
      Here is a hint I previously posted, much to the dismay of people quoting the VW manual that was refering to oil recommendations for a new motor.

      Install a real pressure gauge.
      Determine if your oil pickup is obstructed.
      A 200,000 mile car has worn bearings, which allow more flow, which causes a decrease in pressure, so... use a thicker oil. Start with 10W40.. preferably synthetic. If pressure is still low, go to 20W50
      Be advised, I had one Fool jump in spewing nonsense because I said I would not put 5W30 in a high mileage car.... actually, I wouldn't put it in my riding mower.
      This is a very elementary concept. Your motor will determine what oil weight you need... it conveys this info via the oil pressure gauge.
      It does not matter what a 15 year old VW manual says.
      Your motor is not new.

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •