Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Links back to The Car Lounge (opens in same window)
    Page 3 of 3 FirstFirst 123
    Results 71 to 95 of 95

    Thread: My 300zx Build

    1. Member Swapped6n's Avatar
      Join Date
      Feb 11th, 2010
      Location
      Amsterdam
      Posts
      1,211
      Vehicles
      Track ready, Supercharged R32+ Track-Ready Vw Polo 6N, with GTI motor.
      04-19-2012 12:09 PM #71
      Awesome man! Your build shows that you have MUCH more patience than i ever would haha

      Lets get some more photos of her

      And a video or two?

      Im curious how it sounds!

    2. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      04-19-2012 12:49 PM #72
      Oh there will be LOTS more photos this summer. It hasn't been waxed in almost 2 years now soooo....it'll look better. I've got a friend that is gonna teach me how to do a REAL detail (polish etc) which I am excited for.

      I'll shoot some video after I get it tuned. Right now I'm trying to hunt down an off-throttle rattle. I'm thinking exhaust, but when I kicked the exhaust last night it didn't make any noise

      Maybe I'll post a video of that and some sleuths here can help figure it out.



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    3. Senior Member Air and water do mix's Avatar
      Join Date
      Aug 5th, 2004
      Location
      Southern Indiana
      Posts
      21,385
      Vehicles
      '66 Beetle, '69 VW Fastback and an '08 Fit
      04-19-2012 02:49 PM #73
      Quote Originally Posted by megaDan View Post
      I'll shoot some video after I get it tuned. Right now I'm trying to hunt down an off-throttle rattle. I'm thinking exhaust, but when I kicked the exhaust last night it didn't make any noise

      Maybe I'll post a video of that and some sleuths here can help figure it out.
      I hadn't run into this thread before. The other folks are right, you're a very, very patient guy.

      The bad headwork would've made me absolutely crazy. There's no excuse for sloppy work like that. I don't know which is worse, the fact that they didn't set the valve height correctly or the junk under the ports. Both are pretty unforgivable.

      Have you put a magnetic drain plug in it? They're great for engine break-in, as they hold the little bits of ring that tend to grind away when you're firing. For the same reason, always drain the oil hot!

      As far as that elusive rattle, was the engine hot when you kicked the exhaust system around? That can make a huge difference.

      Keep the faith, man.
      Quote Originally Posted by Boyz in da Park
      Proletariat, Bourgeoise - Everybody smellin' my potpourri...

    4. Member wrigh003's Avatar
      Join Date
      Mar 21st, 2003
      Location
      Birmingham, AL
      Posts
      1,414
      04-19-2012 05:04 PM #74
      I bent the brand-new mower blade on my riding mower the other day, right after I got it home from having a bracket welded back up at the shop, and I very, very nearly flipped it over, shot holes in it, and set it on fire I was so frustrated. Can’t comprehend all the (what, 20?) assemble/disassemble/reassemble troubleshooting steps you’ve done.

      Car looks great. Best of luck with the rest of the shakedown/ironing-out process. In spite of all my better judgement, everything I have heard, and the things I have just seen you go through, I still want one.

    5. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      04-19-2012 10:36 PM #75
      Quote Originally Posted by wrigh003 View Post
      In spite of all my better judgement, everything I have heard, and the things I have just seen you go through, I still want one.
      I took the (very) long way home from work today. Approximately 60 miles through the hills in Northeast Ohio (okay that doesn't sound very pleasant, but the Kirtland Hills/Chardon area has some really nice scenery) in 70 degree weather with he tops off and windows down. Days like today, even if I'm still babying it, make EVERYTHING worth it. Its an absolute dream to drive. Even with the minor annoyances.

      50 miles into my drive I pulled up to a stoplight and it was misfiring at idle and at 18-19 AFR.

      After I babied it home I found a vacuum cap had popped off. and At least it was nothing major. Put a new one on with RTV this time.

      .................................................. ......................................

      There were more than a few occasions when I didn't wanna deal with the car, which is partly why I put it back into storage in the fall instead of trying to finish it up. Especially when its just myself doing the work. But the turning point was my buddy Pat coming to help for a weekend. Just getting the motor to fire was BIG motivation; even if it required more 'redo' work afterwards.

      AND...now that I've done it this many times...its not as much of a hassle. If it wasn't for all the coolant in the system and not wanting to make a mess, I could probably do a timing belt job in 3 hours now. Shutoff to restart.

      If you're on the fence..go get one now. Before they're ALL molested. Its not that bad :-)



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    6. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      06-13-2012 02:27 PM #76
      Originally posted 5-20-12

      Been a while since I've posted.

      I think I've gotten nearly everything sorted out with the car, except for the tune. The car runs good, but there is a funky lean spike right around 2k rpms that I think is killing my torque output.

      Yesterday a couple friends and I drove down to Canton for a dyno day benefit. It was a chassis dyno (more info when I get the graphs).

      Buddy with a SN95 cobra put down 250hp with just pullies.

      284whp and 270 torque for my Z with stock wastegate pressure (12psi). Kinda disappointed. I think a lot of it comes down to the tune. (ashspec chip currently) I really wish I could have been ready for the Specialty Z tune day in Cincinnati. I should get the graphs tomorrow, but now I need to learn how to use my Nistune ECU and software.

      DYNO:



      To be fair, I found out on the ride home that I popped off two vacuum caps and a fuel line. I hope that was the reason for the crappy showing.



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    7. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      06-13-2012 02:30 PM #77
      I thought I had a RMS leak, turns out I never retightened the oil pan bolts after installing it with RTV orange initially. To get to all of the bolts I had to remove the transmission brackets on the driver's side and loosen the bracket on the passenger's side. Since then I haven't seen a drop of oil from the back of the motor.

      I installed a Greddy Profec B Spec 2 boost controller that I found on the forum last week now that my motor is broken in. It feels good to get up to 15 psi again!

      I got an auto NA nistune ecu for a steal a while back, and 91ser came down from Chicagoland again to help adjust the tune. I've been running an Ash tune set up for my 755cc top feed injectors, but after installing the sport 500 turbos and AMS exhaust manifolds I've had a lean spot at part throttle that I wanted to get rid of. After doing a fair amount of reading we learned how to copy the maps from my TT ecu onto my netbook, and transfered them onto the nistune ECU. We went for a drive but were unable to see the effects of our changes. I think we were running into issues with the gear map, so the gear and knock maps were disabled and things really took off from there.

      We pulled some fuel out at the top end (shot for 11.5-12.0) and added some down low (shooting for 14.7 low load) and the car runs SOOO much better. We filled up after about 1/2 tank of highway driving, 1/4 tank of accelleration runs, and 1/4 tank of cruising. 19.996 mpg!!!! Typically I've only seen 20 on 100% highway tanks. I can't wait to see what this current tank gets me. I'm going to need to modify some other rich spots down low, and I want to try and lean out very low load areas some more to improve fuel economy (after doing some more reading on how to tune). I just can't believe how much of an improvement we saw with only a few hours spent in the car.



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    8. Member
      Join Date
      Aug 12th, 2008
      Location
      Savage, MN
      Posts
      1,178
      06-13-2012 03:10 PM #78
      Nice work!

      It's been a fun read. Keep us posted.

    9. 06-13-2012 04:18 PM #79
      I'm jealous that you're getting 20MPG with twin turbos. My N/A 300zx barely hits 18MPG average normally.

      Awesome build btw However, you've practically talked me out of doing a TT swap in the 300zx.

    10. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      06-27-2012 09:09 AM #80
      MPG Update:

      Last weekend I gave the girlfriend a VERY brief overview of how to use nistune, but with her help dialed in the tune on the freeway in 5th from 55-75. AFR at part throttle is almost dead on 14.6-14.8. After filling up on that tank I got 21.9mpg. 75% freeway/country roads, 10% commuting 3.5 miles and back to work a few days, and 15% with the old tune. Looking better!

      I'd like to know how some people are getting 25+ on the freeway. My goal is 22-23mpg on the highway so its not too painful on the wallet for long trips.

      Check me out on fuelly.com for MPG updates.



      Also took delivery of a second MAF, Selin Translator, and oil sandwich plate this weekend. The plan is to take a long weekend over 4th of July to see Cake at Summerfest, help my buddy finish up the V8 install in his slicktop, and install a DOOLZ (dual intake) on my Z. Should be good for quicker throttle response and about 20-30HP. Oil sandwich plate is for oil temp/pressure gages whenever I get a carPC installed. Hopefully this winters project.



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    11. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      08-27-2012 08:29 AM #81
      Originally posted 7-12-12

      First off, I know I need more photos. Just took a 1500 mile road trip and only got one crappy cell phone pic of the Z. Probably because it was dirty most of the time

      Second. 22.9mpg for the road trip. Averaged 22.5, saw best tank of 22.9. I am quite pleased with this, I'm making more power and getting better fuel economy than the last trip I took 2 years ago. I'd still love to break the 23mpg mark. Those numbers are from sitting at 75-80 much of the time with a few spirited runs in between. Wisconsin has some great roads to drive.

      Third! Picked up a Z1 Doolz from my friend in Chicago on my way back. Installed it yesterday in about 30 minutes. (I'll snag pics at lunch) The full setup is, Z1 doolz, silicone couplers, AIP maf (wanted OEM but the guy I bought it didn't state that it was aftermarket) and dual JWT popchargers (only one has a flower pot mod at the moment), and selin translator set to ADD. I've got a few observations.

      1: Driveability is MUCH better. Previously in 5th gear below 1800rpms or so the car would bog down and shudder if i gave it throttle. I really had to be in 4th until 40+mph to drive the car smoothly. Not the case any more, 5th gear is usable down to almost 35mph. This should help fuel economy pretty significantly as most of the roads around here are 35 (boo).

      2: This is completely subjective, but the car seems to drive much smoother. This is both good and bad.

      3: At 15psi power doesn't seem to come on in as much of a RUSH as it did before. This makes the car feel slower. I've only driven with this setup for about an hour, so these observations may change. I did a log last night with nistune and saw TP load hit a new high of 73 (previous TPload max was about 63) so it seems to be making more power. It just doesn't feel that way. I REALLY need to completely redo my tune, but I'm not sure I have the skills for that. I've got a rescaled map created, but I'm afraid to use it. My current TP load scale maxes out at about 44. I'm monitoring everything very closely while driving, but something tells me its not a good idea to have the ECU interpolate that far beyond the chart.

      4: Despite having my ballasts mounted at the outer edges of the engine bay and the selin right in the middle, I still get LOTS of interference. When I tried to pull away at the gas station I killed it because it was running so poorly. It didn't occur to me until the second try that the problem I was seeing was because of the HID's. When I turned the headlights off the car ran great. I need to read up on how people are correcting this.



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    12. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      08-27-2012 08:30 AM #82
      Originally posted 7-16-12

      We were 5 miles from home after 4 hours and 150 miles of driving all day Saturday when the car died at a fairly busy intersection. Barely managed to get it through the intersection and into a driveway.

      Could not connect to the ECU with consult
      Code 55 - All OK
      Aux fan running with key in accessory position
      Car would barely idle (VERY rich) and would die with any throttle.
      CEL was on.

      If I let the car sit for 3 minutes, the fan would not turn on at the turn of the key, but as soon as I gave it throttle it would start with the above symptoms again.

      Called AAA and was home within 30 minutes. I had planned on swapping ECU's in the morning on Sunday because everything I read suggested a bad EPROM or bad ECU (Current ECU has a nistune board). Some others suggested bad MAF, which almost makes sense because I'm running a dual maf setup (1 oem 1 AIP) with a selin translator but that doesn't explain why I couldn't connect to the ECU.

      Sunday I started up the car and drove around the development with no problems. ??? Now I have to drive around wondering when this will happen again.

      I've got a spare ECU and spare single intake ready to swap over in the car in case this happens again. Has anyone else encountered this problem before? Is it possible to have this caused by a bad maf when running the selin? I would think that if one maf is bad (and set to ADD) it would be reading to LITTLE airflow and be running lean. Has anyone ever had a bad nistune board?



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    13. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      08-27-2012 08:31 AM #83
      Originally posted 8-6-12

      Well its happened twice more now. ECU dies after long drives. Swapping to my chipped TT ecu will allow the car to run fine indefinitely. If I drop the nistune ECU back in the next day it'll work fine again. A brief visual inspection of the ecu innards didn't reveal any problems.

      Not really sure what route to take. I'm assuming/hoping its the ECU and not the nistune board that is bad. I guess my next option is to find a cheap working NA ecu and swap the nistune board over.



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    14. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      08-27-2012 08:32 AM #84
      Today

      I got in on the initial offering of the Royalty Performance 13" rear brake group buy, and they were delivered about two weeks ago. However my golf was still up on jackstands with my troublesome steering rack replacement so I couldn't install them.

      I finally was able to tackle this job on Friday with the help of my girlfriend before I took her out to dinner :-) In total, it probably took us an hour to install these, wheels off to wheels on (including the time it took to learn how to adjust the parking brake). Very VERY simple install. I did have some problems with the heat shield rubbing against the backside of the rotor which I had to spend 5 minutes adjusting on Saturday, but nothing major. Unfortunately I haven't had a chance to really test them with any simulated panic stops yet.

      I definitely like the look though. It makes the fronts look smaller, but I like having 13" all around. They look much better under my 18" wheels.

      Crappy photo on the way into work:



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    15. Member PlatinumGLS's Avatar
      Join Date
      Aug 2nd, 2003
      Location
      Shelby Township, MI
      Posts
      15,191
      Vehicles
      5.7, 5.3, 2.0T & 1.0
      08-27-2012 09:16 AM #85
      Great updates (except the stalling)! With an intermittent problem like that, makes me think it might be a loose ground? Good luck

    16. 08-27-2012 10:15 AM #86
      Good work man.

      So what are your future plans with the car?

      PJ

    17. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      08-27-2012 11:51 AM #87
      Quote Originally Posted by PJtree23 View Post
      Good work man.

      So what are your future plans with the car?

      PJ
      I've got this winter's projects pretty much lined up.

      I've got a 2.5" intercooler piping kit waiting to install, still need to purchase larger intercoolers with 2.5" inlets. I'll have my OEM throttle bodies bored out and the plenum matched to account for the larger piping. Dyno tests have proven almost +100 low end tq with this upgrade alone. Combined with my slightly larger than stock turbos, lag should be almost nonexistent with a monster torque curve.

      The seats (and probably interior) will get recovered in charcoal leather, along with a new shift boot and ebrake to go with the red stitched shift knob my girlfriend got me for Christmas last year.

      I plan on moving away from my triple 52mm gauge setup and switching to a double din bezel with a car PC running datascan/nistune. This way I can still monitor oil pressure/temperature/everything else with the sandwich adapter I'll be installing and I won't have to clutter the interior with more gauges.

      Finally, I'll be cleaning up the engine bay and powder coating the plenum and balance tube and valve covers to get rid of the cruddy old aluminum look I've got going on. I really should have done this last winter, but I was too focused on getting it to run after my first ever engine build.

      That will pretty much cover me for performance upgrades. The suspension is still pretty firm, I don't plan on altering that until my bushings start to go. Its a toss-up between that and paint as my next major modification, probably 2+ years down the road. I'm hoping that this winters round of upgrades are all I will need and I can drive it for a few seasons without sinking any more money into it. I've been planning on all of these for the last year, and I don't have anything else I need to do, and I struggle to find upgrades I want to do.



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    18. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      10-06-2012 03:13 PM #88
      Today

      I've been trying to find a local dyno day for a while now, with no luck. So I finally got around to calling Bigshot Dyno down in Stow. I live in a city of 51k people and 100k within 5 miles, and I have to drive almost an hour to the closest dyno. Boo.

      Anywho, I did my first dyno this spring with a chip tune and 12psi and put down a measly 290ish hp. Since then I got Nistune and using ZERO tuning experience dialed in the chip tune on the street and turned up the boost to 15psi. I also installed a doolz intake and selin translator.

      I've got a set of Ash Massives V3 and 2.5" intake piping on the way for install this winter and I wanted to get another baseline prior to that mod, and a comparison from where I was at this spring.

      Runs on a DynoJet reporting STD Horsepower.
      Run 1 broke up a little so we didn't log it.
      Runs 2 and 3 were nearly identical, within 1hp and 1tq at 15psi.



      Run 4 I turned the boost controller back down to 12psi to get a comparison to this spring (plus the dual intake and tune)




      15psi- 351whp and 367tq!!!!!!
      12psi-331whp and 339tq!!

      VERY pleased with these results. My goal of 450whp should be attainable with 17psi and breather mods!



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    19. Member 200HP4dr's Avatar
      Join Date
      Nov 21st, 2001
      Location
      NE. OH
      Posts
      8,102
      10-06-2012 04:19 PM #89
      Maybe I missed it, but what did you do to resolve your random stalling issue?

      Also, great progress on the car. I'm not too far from you, I'd love to check it out.

      Chris
      | 2014 Nissan Altima | 2012 Nissan Leaf | 1988 Mustang GT Conv. | 2000 Honda Odyssey

    20. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      10-08-2012 08:45 AM #90
      Quote Originally Posted by 200HP4dr View Post
      Maybe I missed it, but what did you do to resolve your random stalling issue?

      Also, great progress on the car. I'm not too far from you, I'd love to check it out.

      Chris
      Nope, I think you're right. I couldn't find mention of my 'fix' anywhere.

      Take a look at the photo below (not my ecu, but the same model and you should get the idea).

      The standard Z32 ECU has a main board, and a daughterboard that lies parallel about .75" away on the other side of the casing. The two are connected with a 1" wide ribbon cable. Nistune replaces the standard aftermarket EPROM chip with yet another daughterboard in between the two, right where the ribbon cable is.

      I dissected the ECU looking for loose or bad solder joints, but everything looked good, the only thing that was suspicious was the ribbon cable squished between the 3 ECU boards, and the ribbon cable was up against the backside of the Nistune board, which had many exposed pointed leads. I put some insulating material in these locations and haven't had a hiccup since.

      I'll shoot you a PM, I'd be happy to show it off. Don't expect too much though, engine bay cleanup starts this winter.



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    21. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      10-12-2012 08:14 AM #91


      Ashspec Massives V3 intercoolers delivered. Over twice the size of my current intercoolers, and these have a 2.5" inlet/outlet to mate up with my waiting 2.5" intercooler piping.

      Won't get to install them until late winter/early spring.



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    22. Member megaDan's Avatar
      Join Date
      Jul 11th, 2007
      Location
      Milwaukee Suburbs
      Posts
      1,141
      Vehicles
      1990 300ZX TT, 2002 Jetta TDI
      06-15-2013 12:41 PM #92
      As usual life has gotten in the way of working on the Z, as it seems to do nearly every year.

      Late fall I got a new job and moved back home to Wisconsin in December. I stayed with family until March, when my girlfriend moved up and we found a place to rent. Over the winter I joined forces with a group of friends to build a 24 Hour of Lemons team/car. Our first race was April, and that sucked up nearly all of my free time.


      Formerly the Putt Pirates, now Priority Fail

      While trying to get a street car fully prepped for the track in under 4 months, I was also 'training' for a half ironman I competed in @ the Kennedy Space Center in Florida. Over the course of two months I somehow found time to pull the bumper and intercoolers off the Z, but thats about it. After our first lemons race and after completing the tri in early May I had a few hours a week to spend on the car.


      Ironman trip

      I should probably cover this years planned modifications first. Over a year ago I got a set of 2.5" intercooler piping for a price I couldn't say no to. All of the mods to my Z so far have been focused on making it a fun street car. Sport 500's, exhaust manifolds, 13" brakes, etc. Nothing over the top cost-wise, and mods focused on getting on the power earlier. Last fall I got a set of 2.5" Ashspec V3 Massive intercoolers, and had hoped to install them in the fall with the piping which did not happen. I also picked up a 7" touchscreen to run a carpc with for nistune and gages and etc, but that will have to wait until next year. Ah, almost forgot, I also had RobZ CNC my OEM throttle bodies and I ported my plenum to match. This is gonna be a riot when it is done!

      So...I removed the OEM intercooler piping over the course of two days. The girlfriend was at a bachelorette party or something like that so I had the night to myself. Without even realizing it I spent 7 hours in the garage on a friday night and got most of the car ripped apart and half the piping out. Total to remove the piping was probably about 3-4 hours. Not as bad as I expected, but it could have gone better. Recirc bolts were seized, and almost impossible to reach with the condensor fan still installed. I wish I would have taken pictures. The first thing to remember is to unbolt the dryer bracket from the car, and this will give you all the wiggle room you need for the passenger side. The drivers side was much easier.

      After I got this done the car sat for quite a while before I was able to start installing everything once again. It took a while to figure out how the 2.5" piping would go back on. I installed the intercoolers first, as everyone said to do, which was a good idea. However it took a lot of trial and error to get the right pipes in the right place and in the right direction. I spent a lot of time in front of the computer looking at other installs, but I still had to figure most out myself. I'd say I probably spent 8-10 hours (over the course of multiple days) getting everything fit up right.

      We had another Lemons race last weekend, and our next isn't until November so I can finally focus most of my time on just one car. I got to work on the Z Thursday AND Friday this week, which was enough time to finish the piping install and install the upper plenum.

      This evening's plans are to do a boost leak test and if everything holds up....try and start the car!

      The big challenge this summer will be tuning the car, as I will need completely new maps with all the power I'll be putting down. Technically I should have rescaled my map with the previous round of mods, but the car ran great and I knew another extreme round of mods was not far away. I plan on renting some dyno time and doing it myself but I haven't messed with timing maps before. I've done lots of reading regarding tuning so I think I'll be able to get the hang of it, but I also want to make sure I do it right.

      This is the last set of power-adders I plan on going with so whatever I end up doing for a tune this time will last quite a while. I'll install a LWFW and 1pc driveshaft some day, but aside from that all future mods will revolve around looks and functionality.

      I'll get some pics up later tonight. I'm bored in front of a computer so I figured it would be a good time to update this thread.



      Quote Originally Posted by deftonesfan867 View Post
      Ohio makes me wanna punch babies.

    23. Member Dscot8r!2's Avatar
      Join Date
      Dec 18th, 2012
      Location
      Atl OTP
      Posts
      1,862
      Vehicles
      20th #105, '12 Beetle Turbo, '14 Tiguan R-Line
      06-15-2013 03:07 PM #93
      Dude?! Stop being lazy and get this car done. Ironman competitions, Triathlons, building race cars, working, etc. That should take no more than 18 - 20 hours a day.
      Lots and lots of money spent...

    24. Member todras's Avatar
      Join Date
      Mar 28th, 2001
      Location
      Muskegon, MI
      Posts
      2,135
      Vehicles
      Sold the fun cars. :(
      10-16-2013 10:46 PM #94
      Quote Originally Posted by megaDan View Post
      I'll get some pics up later tonight. I'm bored in front of a computer so I figured it would be a good time to update this thread.
      rynodyno312: Just curious, but what makes it a "controversial" engine?
      Fritz27: The LS7 made some anti-Semitic remarks back in 2008. Look it up.

    25. Member mikerosoft's Avatar
      Join Date
      Mar 20th, 2004
      Location
      Tennessee
      Posts
      2,084
      Vehicles
      1992 300ZX TT, 2002 VW GTI 1.8T
      01-03-2014 11:01 AM #95
      Any updates on the Z?

    Page 3 of 3 FirstFirst 123

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •