Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 6 of 6

    Thread: E brake cluster light wont turn off

    1. Semi-n00b cuchifrito's Avatar
      Join Date
      Jan 20th, 2012
      Location
      VA
      Posts
      17
      Vehicles
      1996/VW/Jetta Trek
      01-20-2012 11:26 PM #1
      mk3 vw jetta 96 trek edition 2.0l

      have checked fluid, and its proper light still on?

      help would be appreciated greatly

    2. Semi-n00b cuchifrito's Avatar
      Join Date
      Jan 20th, 2012
      Location
      VA
      Posts
      17
      Vehicles
      1996/VW/Jetta Trek
      01-21-2012 03:10 AM #2
      car needs to pass inspection which is coming up soon any information on how to fix this problem also was told could be "plugs have been frozen because of the cold weather" not for sure if thats accurate so helps wanted thanks

    3. 01-21-2012 03:04 PM #3
      Yeah, My e-brake light flickers and stays on too when i have the ebrake handle down... same car... its effing annoying... but i can't seem to figure it out... i am starting to think its just my cluster...

    4. Semi-n00b cuchifrito's Avatar
      Join Date
      Jan 20th, 2012
      Location
      VA
      Posts
      17
      Vehicles
      1996/VW/Jetta Trek
      01-21-2012 11:23 PM #4
      i bought the car in the end of the fall after about a month when it started to get cold ebrake light would flicker but id push down the ebrake completely and the flicking would stop but recently makin sure the ebrake is down completly just doesnt fix the problem honestly the ebrake light is just annoying thats the problem and being that my ebrake works exactly as it should be is worst

    5. Junior Member
      Join Date
      Apr 15th, 2012
      Location
      Mercersburg Pa
      Posts
      42
      Vehicles
      97 Vw Cabrio Highline, 99 Dodge Ram 1500 SLT Laramie 4x4
      04-22-2012 08:28 PM #5
      Prob. need a new switch for the ebrake I think a good way to check would be pull the console up unplug the sensor and put a jumper connecting the wires of the plug to see if the light goes out if that works then you need a switch
      1997 VW Cabrio Highline convertable
      2.0 liter ABA engine all stock
      black top Ripped rear seam both sides FIXED
      5 speed with noise in reverse
      All factory

    6. Member ABA.slo's Avatar
      Join Date
      Apr 11th, 2012
      Location
      Coventry, Ct
      Posts
      260
      Vehicles
      2000 BMW 323ci; 1997 VW Jetta 2.0 (daily); 1990 Golf
      05-15-2012 06:17 PM #6
      My car just started doing the same thing. Anyone try get a new brake switch?
      MK6 GTi
      1997 Jetta (totaled)
      1990 Golf (95 vr6 swap, 6 speed, mk3 interior, In progress...)
      1998 Jetta Gl (Resurection!)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •