Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 4 of 4

    Thread: 93' CS100 2.8l question about the MAF

    1. n00b
      Join Date
      Mar 9th, 2012
      Posts
      6
      Vehicles
      2008 693cc Arctic Cat ATV Diesel, 2008, Ford F-350 6.4l turbodiesel, 2007 VW Touareg TDI 5.0
      03-11-2012 12:09 AM #1
      Just wondering if anyone knows what the MAF reading should be on the VAG-COM. It says 7 g/s as it is and my mechanic thinks it should be reading about 3 g/s (at idle).

    2. 03-11-2012 06:01 PM #2
      It should read about the same as engine displacement at idle. So 2.8 displacement reading should close to that. So 3 g/s sounds right.

      Sent from my SGH-T989 using Tapatalk

    3. n00b
      Join Date
      Mar 9th, 2012
      Posts
      6
      Vehicles
      2008 693cc Arctic Cat ATV Diesel, 2008, Ford F-350 6.4l turbodiesel, 2007 VW Touareg TDI 5.0
      03-12-2012 02:00 PM #3
      Thank you for that. Any thoughts as to why it would be registering about twice the airflow? I think one of the O2 sensors is faulty too. Where is a good place to buy a new one? I pulled a used MAF off a 94 CS100 in the wrecking yard and it registered the same 7g/s. I doubt they'd both register the exact same number and both be wrong. So it's drawing in too much air?

    4. 03-22-2012 08:42 AM #4
      If you have an air leak that would defenetely cause the problem. I would stick to dealer parts if possible especially with o2s. If the junk yard maf is reading the same you might want to check the basics such as air leaks, power and ground going to maf.

      Sent from my SGH-T989 using Tapatalk

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •