Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 2 of 2

    Thread: 94 Jetta No Turn Signals NEED HELP

    1. Member turbo_powered's Avatar
      Join Date
      Dec 4th, 2007
      Location
      Cedar Rapids, IA
      Posts
      724
      Vehicles
      02 GTI 337
      03-14-2012 11:27 PM #1
      So here's the deal. My tun signals dont work. At all. No lights on the dash for them or any of that. However the Hazard light still currently work. I have replaced every single fuse in the block under the dash. Changed the Relay. and installed a new Signal switch from German Auto Parts. The plug-in for the Turn Signal stalk doesnt look corroded. I think It could be a ground issue but then the Hazard lights should not work either in that situation. Checking the bulbs is pointless. Being that all light up when using the flashers. I'm really hoping somebody can help here. I'm about to rip the fuse block out. However again. Relay for the Flasher and the Turns are the same thing. I'd think if one works both should work. Thanks for the Help in advance!

    2. Member turbo_powered's Avatar
      Join Date
      Dec 4th, 2007
      Location
      Cedar Rapids, IA
      Posts
      724
      Vehicles
      02 GTI 337
      03-15-2012 10:06 PM #2
      I'll leave this post up incase somebody else has this problem and needs it. I found my issue. The fuse slot was worn out. Fuse wouldnt fit tightly so i had a bad connection and no working turn signals. I used a small 90 degree pick and pryed the tabs out a little for a tighter contact. Will be replacing the block soon though to avoid further problems.

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •