Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 6 of 6

    Thread: Time for a new cluster, or?

    1. Semi-n00b HappyDude69's Avatar
      Join Date
      Apr 7th, 2003
      Location
      Langley, BC
      Posts
      18
      Vehicles
      2000 Bora GTX
      03-17-2012 06:45 PM #1
      The center Screen on my cluster seems to acting up....

      But it's not always that bad...


      It seems like it does that more with time as if it over heats.. But not always and can fix itself after a longer period of time. But I also noticed (can't see in the pic) that when it's "good" it still messed up just not bad enough to show on camera.

      Another note, after bending the pin to disable the DRL, the cluster will flicker as if there a loose connection... When the lights are on, and the cluster brightness is not full, it will flicker to full brightness.. Some times more often then others.... The other lights in the dash (climatics controls, etc) do not flicker and stay the proper dimness. If I have the brightness on full, there is no flicker.

      Am I cluster fäwked? Or is there a fix for those issues?

    2. 03-22-2012 04:07 PM #2
      1. Everybody's cluster dims in the heat as it gets old.

      2. There's no flicker when brightness is full because the lights are flickering brighter, not dimmer. Mine does the same thing, could be the adjustment control. But I still have DRLs. Replacement headlights, but they have DRLs. If I figure it out, I'll post.

      Why do people insist on turning those off? It's illegal, and much safer to have them on. Something about VW drivers wanting lights off, while other drivers are turning on all kinds of lights on the daytime........ I'm beginning to thinmk the latest gen Mustangs have no off switch for the fogs.

    3. Semi-n00b HappyDude69's Avatar
      Join Date
      Apr 7th, 2003
      Location
      Langley, BC
      Posts
      18
      Vehicles
      2000 Bora GTX
      03-25-2012 07:55 PM #3
      Yeah, I can either replace the screen by getting one on eBay and soldering on (not likely) or replace the cluster... Thinking of a euro full display one . (not in a hurry to get it a cluster for the reason as the screen still works).

      As for the flicker, it only just started just after I disabled the drl. Here, it's not illegal... The book here says "Vehicle may be equipped with daytime running lights". I see lots of euro and other imports with drls off. But I too share same thought about the mustang fogs and add that to a few different SUVs and trucks.. Anywho... I was thinking that when I did that I the drl, that I might have knocked a cable a tiny bit loose on the dimmer switch.. But I think it's just the cluster since non of the other lights associated with the dimmer switch flickers.

    4. Member
      Join Date
      Apr 1st, 2009
      Location
      Piedmont Triad, NC
      Posts
      235
      Vehicles
      2002 GTI
      03-30-2012 12:54 AM #4
      Quote Originally Posted by HappyDude69 View Post
      The center Screen on my cluster seems to acting up....

      But it's not always that bad...


      It seems like it does that more with time as if it over heats.. But not always and can fix itself after a longer period of time. But I also noticed (can't see in the pic) that when it's "good" it still messed up just not bad enough to show on camera.

      Another note, after bending the pin to disable the DRL, the cluster will flicker as if there a loose connection... When the lights are on, and the cluster brightness is not full, it will flicker to full brightness.. Some times more often then others.... The other lights in the dash (climatics controls, etc) do not flicker and stay the proper dimness. If I have the brightness on full, there is no flicker.

      Am I cluster fäwked? Or is there a fix for those issues?
      Yeah, your lights are brighter mine are totally dim. so far I swapped two clusters, a used one, same thing. it is dark on cluster when I turn on lights, only lights flicker when High beams are on with the funny noise, low beam lights make no diference in providing light on cluster even when the dimer is all the way up. I think I will splice one and solder and see what hapen.
      What you do does not matter, how you do it does.

    5. Junior Member
      Join Date
      Jul 24th, 2005
      Location
      Southeast VA
      Posts
      48
      Vehicles
      2004 VW Jetta GLI 1.8T
      04-10-2012 09:56 AM #5
      Any updates to this? I have the same problem. My cluster is totally fine except for the center red computer display. It used to have good days and bad days, but coincidentally or not, after I switched out my alternator, there are only bad days. It's dimmer than it's ever been and I can barley see it. Is there a fix for this or is it just for the solder-comptetent?

    6. Semi-n00b HappyDude69's Avatar
      Join Date
      Apr 7th, 2003
      Location
      Langley, BC
      Posts
      18
      Vehicles
      2000 Bora GTX
      05-04-2012 02:02 AM #6
      Well, my display still acts the way it is... (not all pixels dim the same amount... Fried/old display) when it's on for a while... As for the two here that say it stays dimmer then the rest of the cluster... If its like mine (not all pixels are the dimness) then its just a case of an old display showing its age... But of the whol thing is dim equally, then there is something else messing up... See my statement below and try using a buddies known good switch to see if that makes any difference.

      But, funny story.... I replaced my light switch with a new euro switch and didn't bend the drl pin yet.... The cluster doesn't flicker when I dim it now!

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •