Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 4 of 4

    Thread: "Brake Fault" shows on cluster and brake light on

    1. 04-20-2012 12:36 PM #1
      Periodically when I stop, not always, maybe once or twice a day. The message display will beep, "brake fault" will show up and brake light illuminates. When I make my turn or continue driving the message display clears (returns to mileage, temperature and brake light goes out) in about 15 seconds.

      There is no abs light, no codes in brake system

      I have made abs stops on a dirt road, No problems or lights.

      The problem oly occurs under normal driving, I do not feel any thing wrong in the pedal or braking system, no pulses, shimmies, or clunks nothing

      I have ECS slotted rotors, red stuff pads, and stainless steel brake lines.

    2. 04-20-2012 12:40 PM #2
      I forgot to mention an 03 gti with 170, miles000

    3. Member greyhare's Avatar
      Join Date
      Dec 23rd, 2003
      Location
      Corvallis, OR
      Posts
      2,414
      Vehicles
      '96 Jetta, '78 Rabbit, '79 GMC 3/4T 4x4, 2013 BMW F700GS
      04-20-2012 12:59 PM #3
      Check the fluid level.

    4. 04-20-2012 04:30 PM #4
      The fluid level is good

      The brake light would illuminate if low

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •