Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 11 of 11

    Thread: g60 issue

    1. 07-15-2012 08:19 PM #1
      Im having issue with my g60 just want to try and get some idea's to what it can be. Ive checked everything but continues to do it. i have BBM stage 4 kit with 62mm pulley. when i put it in first seems good WOT shift to second and feels like i hit a wall then starts to pull again. also does it in 3 gear like the power cuts in and out at high RPMs. Feed Back would help.

    2. 07-16-2012 12:44 PM #2
      Well i put my Pressure up to 43psi seems like its not doing it as much. Wondering if i should go any higher? Ive been told its way to low that i should be at around 50psi at Idle. Does that sound right? Just seems very high.

    3. Member crazynorweegian's Avatar
      Join Date
      May 8th, 2006
      Location
      Portland, OR
      Posts
      2,937
      Vehicles
      1990 1.9L G60-ST5 Black, 02 S60 2.4t
      07-16-2012 01:07 PM #3
      Quote Originally Posted by jeffs vw View Post
      Well i put my Pressure up to 43psi seems like its not doing it as much. Wondering if i should go any higher? Ive been told its way to low that i should be at around 50psi at Idle. Does that sound right? Just seems very high.
      What exactly are you measuring at 50PSI? The G60 supercharger cannot produce that much boost, so either you are doing something very wrong or you are not being clear about what you are measuring. If you are talking about fuel, the stock FPR flows about 2.5 bar at idle (3 bar rating) and the common upgrade for the car is a 3.5 bar rated FPR that normally flows somewhere around 3bar at idle.
      Stephen
      Portland, OR
      Black 1990 1.9L Stage 5 G60 - keeper
      Corrados decay in a way that can only be measured using quantum physics
      http://sites.google.com/site/corradoproject/

    4. 07-16-2012 04:01 PM #4
      Im running the BBM Adjustable Fuel Pressure regulator I set it at 43psi at idle. Should it be higher? im running 30lbs injectors with stage 4 chip? I also put my co pot at 450 but seems like it hesitate or runs into a wall sometimes. Is that because i need to raise my Fuel Pressure more? My Timing is set at 6 stock. Just try to figure this out along with some tips. Thanks

    5. Member crazynorweegian's Avatar
      Join Date
      May 8th, 2006
      Location
      Portland, OR
      Posts
      2,937
      Vehicles
      1990 1.9L G60-ST5 Black, 02 S60 2.4t
      07-17-2012 11:08 PM #5
      Quote Originally Posted by jeffs vw View Post
      Im running the BBM Adjustable Fuel Pressure regulator I set it at 43psi at idle. Should it be higher? im running 30lbs injectors with stage 4 chip? I also put my co pot at 450 but seems like it hesitate or runs into a wall sometimes. Is that because i need to raise my Fuel Pressure more? My Timing is set at 6 stock. Just try to figure this out along with some tips. Thanks
      Ever so slightly more wouldn't hurt. That is 2.9 bar or so. Do you have a wideband? (your answer should be yes). You really can't troubleshoot this stuff very well without one.
      Stephen
      Portland, OR
      Black 1990 1.9L Stage 5 G60 - keeper
      Corrados decay in a way that can only be measured using quantum physics
      http://sites.google.com/site/corradoproject/

    6. 07-18-2012 12:53 PM #6
      Well i didnt fix the issue but i put my 68mm pulley on it and set my co pot to 500 and put my fuel pressure at 43psi and feel great. Guess that sucker didnt like the 62mm pulley

    7. Member crazynorweegian's Avatar
      Join Date
      May 8th, 2006
      Location
      Portland, OR
      Posts
      2,937
      Vehicles
      1990 1.9L G60-ST5 Black, 02 S60 2.4t
      07-18-2012 03:09 PM #7
      Quote Originally Posted by jeffs vw View Post
      Well i didnt fix the issue but i put my 68mm pulley on it and set my co pot to 500 and put my fuel pressure at 43psi and feel great. Guess that sucker didnt like the 62mm pulley
      What was your boost when you had the 62 on vs the 68? The answer should not be that you did not have a boost/vac gauge.
      Stephen
      Portland, OR
      Black 1990 1.9L Stage 5 G60 - keeper
      Corrados decay in a way that can only be measured using quantum physics
      http://sites.google.com/site/corradoproject/

    8. 07-18-2012 06:56 PM #8
      [QUOTE=crazynorweegian;78261790]What was your boost when you had the 62 on vs the 68? The answer should not be that you did not have a boost/vac gauge.[/

      62mm pulley hitting about 17 to 18 psi
      68 like 13 14 in high rpm range like 5000 to 6000

      Keep in mind i have my Manifold Ported & Throttle Body
      Head is ported
      and im running front mount intercooler also.

      so i believe im losing psi because of all these upgrades which i expected..... But seems to be running really strong.

      And nothing better than having that power in a 83rabbit

    9. 08-24-2012 06:09 PM #9
      After all figured out my problem!!!!

      Thanks Jason @ BBM for all the tips

    10. Member weejunGL's Avatar
      Join Date
      Feb 2nd, 2005
      Location
      Norwegen
      Posts
      1,479
      Vehicles
      MKII G60 Syncro
      08-25-2012 03:00 PM #10
      and the problem was?

    11. 08-25-2012 05:56 PM #11
      Quote Originally Posted by weejunGL View Post
      and the problem was?
      Clogged catalytic converter....

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •