Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 2 of 2

    Thread: Turn Signals Stopped Working Completely

    1. 08-28-2012 10:25 AM #1
      Hey Everyone, I'm completely new here. I have a 2005 VW Jetta 2.0 that I've owned for 3yrs now. It's my first VW and I'm dead-set on not making it my last. I love this car.

      Anyway, onto the issue....

      About a week ago my turn signals were clicking very slowly and would cut out intermittently. Then within a day, they stopped working all together. No lights on the outside, on the dash and no clicking. When I go to put them on, it literally makes no sound and does nothing.

      I've checked the rear bulbs and they're okay. I checked the fuse and that's fine too. I talked to my neighbor about it and he thinks it might be the relay. I don't know much about cars, but I've been willing to learn and want to start fixing things myself when I can.

      Does anyone have any advise on what the problem could be? If it's the relay, is there somewhere online that tells me how to replace the relay on a 2005 Jetta?

      Thanks in advance.
      Last edited by Yogi0421; 08-28-2012 at 01:08 PM.

    2. Member ps2375's Avatar
      Join Date
      Aug 13th, 2003
      Location
      Meridian, ID
      Posts
      11,446
      Vehicles
      80 Rabbit(DEAD), 94 Golf
      09-18-2012 01:37 AM #2
      The relay for the turn signals is the emerg flasher sw.(the red triangle sw in the dash) They are known to go bad.
      Tradition is the art of making the same mistake repeatedly, on purpose.

      FS:MkI low back front seat upholstery(new)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •