Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 30 of 30

    Thread: 2013 GLI Issues and Problems?

    1. Member
      Join Date
      Sep 8th, 2012
      Posts
      104
      Vehicles
      2013 GLI A/Nav DSG BLK
      09-08-2012 01:20 AM #1
      Hello,

      New to the VW world save for my wife who owned a 2004 GTI when it was new. She complained about problems GALORE.

      Is this common in the new Jetta's/GLI's?

      Are there signs I should look out for when test driving?

      Thanks,

      aaron

    2. Member
      Join Date
      Jul 30th, 2012
      Location
      Buffalo, NY
      Posts
      687
      Vehicles
      MkVI 2.5 SE, RIP 1990 Jetta Wolfsburg
      09-08-2012 03:30 AM #2
      Go for a test drive. If you notice things you don't like, drop it. There are people with problems with 2.5 Jettas, there are problems with Camrys.

    3. Member
      Join Date
      Jan 6th, 2012
      Location
      Istanbul Turkey
      Posts
      212
      Vehicles
      2011 VW Jetta 1.4 TSI Comfortline 160 PS DSG-2013 Citroen DS5 THP
      09-08-2012 05:44 AM #3
      I wonder who in the world has bought a 13 MY,driven enough miles to experience problems and review....

      There are no significant pains in a Jetta Mk6, the only part to be decided is the trim and engine choice.....
      And as NA spec Jetta's are not equipped like EU spec Jetta's most of the customers go for a 2.0 TSI engined Version.
      EU spec owners are lucky i guess compared between two vehicles specs...

    4. Member
      Join Date
      Sep 8th, 2012
      Posts
      104
      Vehicles
      2013 GLI A/Nav DSG BLK
      09-09-2012 12:59 AM #4
      That's the point, if there were noticeable standouts in the 2013, then I'd have concern. There were quite a few reports on the 2012's that I will certainly look out for though.

      aaron

    5. Member BetterDays's Avatar
      Join Date
      Mar 13th, 2012
      Location
      Northern Ohio
      Posts
      197
      Vehicles
      2013 GLI Autobahn w/ Nav; APR Stage I
      09-10-2012 01:18 PM #5
      5 days, 600+ miles, no problems yet.

    6. Member
      Join Date
      Aug 14th, 2012
      Location
      TEXAS
      Posts
      135
      Vehicles
      2013 VW GLI AUTOBAHN
      09-10-2012 01:33 PM #6
      18 days. 800 miles. About 600 of those in city traffic. All is well.


      '13 GLI Autobahn

    7. 09-10-2012 01:55 PM #7
      no rattles????

    8. Member
      Join Date
      Aug 14th, 2012
      Location
      TEXAS
      Posts
      135
      Vehicles
      2013 VW GLI AUTOBAHN
      09-10-2012 03:14 PM #8
      None yet for me. And the roads in my town aren't the smoothest.


      '13 GLI Autobahn

    9. Member BetterDays's Avatar
      Join Date
      Mar 13th, 2012
      Location
      Northern Ohio
      Posts
      197
      Vehicles
      2013 GLI Autobahn w/ Nav; APR Stage I
      09-10-2012 07:43 PM #9
      Heard a rattle today - will investigate.
      Happened going over railroad tracks.
      Going to see what is in the console and glovebox first, but it sounded more rear in the car.
      Before it hits the dealer, I need to be able to duplicate it.

    10. Member
      Join Date
      Sep 8th, 2012
      Posts
      104
      Vehicles
      2013 GLI A/Nav DSG BLK
      09-10-2012 10:57 PM #10
      Sounds good so far.

      I have a feeling the 2013's have been dutifully addressed. We know about many of the obvious changes, but I have a feeling there were many more changes in production, basic engineering, etc... in order to avoid more complaining.

      $.02

      aaron

    11. 03-05-2013 03:38 PM #11
      Got a 2013 GLI Autobahn w/NAV and DSG in October. I found a little nub on the hood that looked like a tiny paint defect. I experimented with clay bar and it came right off. Apparently it was a bit of the adhesive that holds on the the shipping wrap.

      After 4000 miles that is the only problem, and it wasn't really a problem. The body is tight and no rattles or rubs. The paint is flawless. Interior finish is perfect. Stitching is all done neatly and looks great. Everything fits well. I am very favorably impressed with the build quality of the car, and the performance and driving pleasure factor is very high. So I think those Mexican robots are doing their work as well as the German robots. (And I live in Germany )

      I have noticed a few GLI owners do not like the Dunlop allweather tires that VW supplies. But they are performing well for me even on the autobahns at high speed. I haven't any complaint about them, but I am told that the tread life is not very long. Time will tell.

    12. Member silver_z33's Avatar
      Join Date
      Apr 14th, 2010
      Location
      Lindenhurst, NY
      Posts
      340
      Vehicles
      2013 GLI Autobahn with Nav
      03-05-2013 03:44 PM #12
      I had one irritating rattle from the front part of the headliner. Drove me crazy until I realized my gf left her sunglasses in the sunglasseses holder when she took my car out without my knowing. I didn't even know she knew how to drive a manual prior lol. Now I'm rattle free...still have the gf though...
      I just want a girl to trip in front of me so I can say finally say bitches be trippin and have it be literal.

    13. Junior Member Andrud's Avatar
      Join Date
      Feb 26th, 2013
      Location
      Ontario, Canada
      Posts
      30
      Vehicles
      2013 GLI, 2009 WRX, 2002 Civic
      03-05-2013 05:47 PM #13
      Quote Originally Posted by silver_z33 View Post
      I had one irritating rattle from the front part of the headliner. Drove me crazy until I realized my gf left her sunglasses in the sunglasseses holder when she took my car out without my knowing. I didn't even know she knew how to drive a manual prior lol. Now I'm rattle free...still have the gf though...
      Lol.

    14. Member JCP281's Avatar
      Join Date
      Nov 17th, 2012
      Location
      Texas
      Posts
      125
      Vehicles
      2013 Volkswagen Jetta GLI
      03-05-2013 07:58 PM #14
      The only thing that irritates me about mine are the rattles. There is a rattle coming from the front firewall/dash thats very irritating. My first oil change they are going to fix it. I almost wonder if its wastegate rattle.

    15. 03-06-2013 08:00 AM #15
      I'm currently replacing both front tires due to bubbles. Was told it's due to potholes and I don't have road hazard coverage. Tires are 260 a piece. Also I feel the car is slightly underpowered but I'm also running stock. If you have the option get the road hazard coverage for the tires. I didn't have the option and now replacing the tires after owning the car for 2 months with 2k miles on the tires.....

    16. Member UberWgn's Avatar
      Join Date
      Dec 31st, 2010
      Location
      Annapolis, MD
      Posts
      407
      Vehicles
      MK6 GLI (AB) CW
      03-06-2013 09:41 AM #16
      13 GLI AB (DSG) 2k miles all HWY and no problems yet.
      ///MK6 GLI (Autobahn) DSG--///Solo Werks///GIAC STG 1///Podi Golf R (true blue) boost gauge///AWE touring cat-back (DB tips)///Induktion motorsports STG 1&2 intake///AWE DP

      Instagram--Listen2DnB

    17. Member dnchattan's Avatar
      Join Date
      Jul 2nd, 2012
      Location
      MA
      Posts
      391
      Vehicles
      2013 GLI DSG
      03-06-2013 10:23 AM #17
      '13 GLI AB+navi DSG @ 8k miles. Bunch of rattles that I still need to get fixed, but no other issues so far. Taking it in for my 10k service soon.

    18. 06-02-2013 10:26 AM #18
      Who all has experienced these issues:

      First week the airbag module went out, rear driver side speaker replaced.

      We have owned the car for 18 months now and had it shipped to Germany due to being stationed here now discovered water leak in car only when A/C turned on and driving the driver side floor board gets soaked. I have had it to a german Audi/VW dealership to get it looked they had it for 2 days and couldn't find the issue, then took it to Italian VW dealership to get the same issue looked at and they told me there was no problem but when I picked it up and drove home with A/C on I picked my floor mat up and the carpet was soaked. It will be going back to the dealership this friday and I'm trying to get VW America to buy car back so that I can get one that is not a lemon. Oh and the check engine light has started to come on this is the second time in a week it has illuminated but car still drives fine. Dealership reset light and said everything checked out and now its on again for the second time. Anyone have issues like this before. Love this car but wish we didnt' have the problems to go along with it.

    19. 06-02-2013 10:29 AM #19
      Quote Originally Posted by ATBGLI12 View Post
      Who all has experienced these issues:

      First week the airbag module went out, rear driver side speaker replaced.

      We have owned the car for 18 months now and had it shipped to Germany due to being stationed here now discovered water leak in car only when A/C turned on and driving the driver side floor board gets soaked. I have had it to a german Audi/VW dealership to get it looked they had it for 2 days and couldn't find the issue, then took it to Italian VW dealership to get the same issue looked at and they told me there was no problem but when I picked it up and drove home with A/C on I picked my floor mat up and the carpet was soaked. It will be going back to the dealership this friday and I'm trying to get VW America to buy car back so that I can get one that is not a lemon. Oh and the check engine light has started to come on this is the second time in a week it has illuminated but car still drives fine. Dealership reset light and said everything checked out and now its on again for the second time. Anyone have issues like this before. Love this car but wish we didnt' have the problems to go along with it.
      Forgot car is 2012 with 16K miles on it.

    20. 10-10-2013 05:00 PM #20
      Purchased car only 2 week ago...
      Everytime the car comes to a complete stop and go, the door keeps auto locking itself (sounds like it is coming from the pass. side)
      Anyone have the same issue???
      It is in service for 4 days now...=/

    21. 10-10-2013 05:20 PM #21
      I hate the fact that the GLI doesnt come 300hp from the factory!! LOL just kidding...

      I had a 2012 Jetta SE and drove it for 10k miles in 8 months with no issue except for the horn and stupid door speakers. I recently traded that for a 2013 GLI autobahn no nav and drove about 500 miles in 3 weeks with no issue so far. My only complain from switching is that I cant use regular gas anymore but I dont think you are concern about that.

      Needless to say, to me the MK6 styling/design/rigidness is top notch. I've had two B5 S4 and a B6 S4 in the past and I am more excited about this MK6 Jetta over them.

      My 2cents.

    22. 10-10-2013 06:50 PM #22
      One year of ownership of the 2013 GLI (autobahn with nav and dsg) for me with no rattles or issues. I'm hoping it stays this way as I love the car so far!

    23. Junior Member
      Join Date
      Mar 19th, 2012
      Location
      Orange County CA
      Posts
      43
      Vehicles
      2013.5 GLI Autobahn w/NAV DSG - FSM
      10-10-2013 08:24 PM #23
      I got my 2013.5 GLI Autobahn w/ Nav ~2 months ago, 2000 miles already and no major issues except the tires. I love everything about the car, the sturdiness of the ride, the pickup, all the little details. I'm coming from a 2005.5 GLI (which I loved), but this thing is better in every single way. Excited to lower it and do some mods once the cashflow is right.



      Quote Originally Posted by Dkg010 View Post
      I'm currently replacing both front tires due to bubbles. Was told it's due to potholes and I don't have road hazard coverage. Tires are 260 a piece. Also I feel the car is slightly underpowered but I'm also running stock. If you have the option get the road hazard coverage for the tires. I didn't have the option and now replacing the tires after owning the car for 2 months with 2k miles on the tires.....
      THIS. My only complaint so far is the crap stock tires. I heard a lot of complaints about them, and I have some of my own. There's a lot of slipping going on, and taking sharp turns and accelerating I get some wheel hop. Not the best tires by any stretch..

      In the first week of owning the car, I maybe could have hit a pot hole earlier or something... but didn't see anything out of the ordinary.. I was just cruising down the highway and the right front tire just BLEW OUT going like 75MPH. Luckily I was able to pull over safe. Tire was completely destroyed, magically the wheel was safe. Tire shop and VW said it wasn't covered by warranty because I probably hit a nail or something. I bitched to corporate and got them to cover it. A $280 cheapo tire.... huh.

      But I ended up buying the road hazard coverage in case that happens again. I can't wait to put some actual good tires on this thing though.

    24. n00b
      Join Date
      Mar 31st, 2014
      Location
      Ft. Lauderdale
      Posts
      1
      Vehicles
      2013 Jetta GLI 2.0 TSI/DSG - 6 speed auto
      04-26-2014 12:30 PM #24
      i was returning to ft Lauderdale from north Carolina 200 miles from home in a convoy with some random people going 88-90 I was 5th in line absolutely did not hit anything (perfectly sunny day 11 am not a cloud in site) tire blows out slight drift then get it under control dealer would not cover there was not a knick anywhere in the tread the inside side wall had blown all the way around it was my right rear tire I had two gym bags with close me and my wife in the front seats no extra weight at all cheap ass expensive ass tire

    25. Junior Member
      Join Date
      Mar 2nd, 2014
      Location
      Atlanta, GA
      Posts
      56
      Vehicles
      2012 VW GLI
      04-26-2014 01:16 PM #25
      I'm not sure they've been around enough to give you a "what to look out for" sort of list, especially if you're buying brand new. With that being said, it appears that there are a lot of TSBs out for this car which means VW has been addressing the issues and, assumedly, resolving them for newer vehicles. As with most cars, the first couple years of a new production are where the final kinks are worked out (I suppose this is not unlike testing your code in production ). I recently drove a 2014 Jetta SE and in general, it felt much more sorted out than my 2012 GLI did. Finally, the FSI motor was just generally more unreliable compared to the new TSI motor.

      Here's a list of TSBs
      2012 GLI Silver Metallic
      Bone Stock

    26. Member amargaretis's Avatar
      Join Date
      Jan 10th, 2013
      Location
      So Cal
      Posts
      363
      Vehicles
      2013 GLI- 67 BuG
      04-26-2014 03:50 PM #26
      2013 GLI, 21.5k miles and beat the car up good. NO issues other than typical interior rattle oh and the stereo is junk. Other than that, diggin this car.
      67 bug built to S%$t - '13 GLI W/ risking warranty needs /// making some bread to spread the wealth /// only posting shiat on shiat worth posting

    27. Junior Member urielD's Avatar
      Join Date
      Dec 24th, 2013
      Location
      Orlando, FL
      Posts
      21
      Vehicles
      2012 VW GLi Autobahn
      04-28-2014 04:21 PM #27
      '12 GLI - 37k miles -

      Around 30k miles I threw a P2015 code (intake manifold runner working intermittently). Took it to VW, replaced under warranty, no issues since.

      Apparently, this is a known thing with the 2.0T. I did my research before taking it to the dealership just in case they tried to pull a fast one on me.

      Other than that, I do hear some rattling coming from the rear subwoofer. I'm planning to upgrade my audio in its entirety so when I do, I'll look for the rattle. Until then, I'm ok with it. It only rattles when the sub hits a certain bass note.

    28. Semi-n00b Yng_Polo's Avatar
      Join Date
      Jun 27th, 2013
      Location
      SW Michigan
      Posts
      10
      Vehicles
      2013 VW GLI
      04-28-2014 08:13 PM #28
      I have a 13 GLI Autobahn 6speed manual. I purchased my car new in March of 13 and it currently has 28,000 miles. The only issue I've had so far is from the Dunlop tires, and wastegate rattle. So far so good!

    29. Junior Member
      Join Date
      Aug 9th, 2013
      Posts
      48
      Vehicles
      2013 Jetta GLI
      04-28-2014 11:04 PM #29
      Quote Originally Posted by Yng_Polo View Post
      I have a 13 GLI Autobahn 6speed manual. I purchased my car new in March of 13 and it currently has 28,000 miles. The only issue I've had so far is from the Dunlop tires, and wastegate rattle. So far so good!

      While only 5K miles, same timeframe. Zero issue except for Dunflops. Have a set of Michelin SS coming tomorrow.

    30. Member
      Join Date
      Aug 5th, 2013
      Location
      USA
      Posts
      133
      Vehicles
      His: 2013.5 Tornado Red GLI Autobahn w/ Nav - 6MT Hers: 2009 Salsa Red EOS Komfort - 6MT
      04-29-2014 11:25 AM #30
      2013.5 GLI Autobahn + NAV (6 speed), took delivery in August...

      Only real issue I had was one day on my way to work, I pushed the clutch pedal in to disengage out of first, heard a 'POP' and it felt like the clutch pedal broke off... Once I got the car pulled over and looked down, the pedal was sitting on the floor (depressed position, just didn't return to the 'up' position, though the clutch was still engaged...

      Called VW Roadside, had them tow it to the closest dealer, who looked at it, popped the pedal spring back into place, and it has been fine since.

      After getting the car back, the clutch pedal felt much smoother than it had previously, even though it felt 'fine' to me before the incident... So I think the spring was never really in properly when it left the factory.


      Only other complaint was I thought I had a rattle issue that I was trying to chase down for a couple of months... Ended up being something I left in the little cubby on the backside of the center console... I never noticed anything in there because I don't sit in the back seat. Once I took that out, car returned to rattle-free status. *knock on wood*
      GLI Mods: VAG-COM Mods, Auto Headlights w/Euro switch + eBay Module, Soundaktor delete, Passenger under-seat drawer, full interior LED kit(deAK), plastic battery box, DG Short Shifter, Winter Mode: OEM Carrier Bars + Ski attachment + 17" Anthracite Goal wheels + Blizzak LM-32 (225 45 R17) (Winter mode currently offline) EOS Mods: VAG-COM Mods, Auto Headlights w/Euro switch + eBay Module, Passenger under-seat drawer

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •