Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 12 of 12

    Thread: Speedo not working and ABS Module will not keep coding

    1. n00b chrisqc's Avatar
      Join Date
      Aug 7th, 2008
      Location
      Montreal Quebec
      Posts
      7
      Vehicles
      1992 Saab 9000T,1997 audi A4 2.8l
      10-02-2012 02:28 PM #1
      The car is a 2003 Audi A4 1.8T with a manual transmission.The original complaint was speedometer
      inoperative.Our scan showed a defective ABS sensor left front.We did a pin to pin continuity test and the circuits showed no breaks.We replaced the left front abs sensor and also tried with 2 other new sensors and swapped it with the right front ABS sensor and retested each time.The same code came back and the speedometer is still inoperative.A recheck of the circuit shows continuity to and from the sensor as ok,no shorts or breaks.We ordered a new ABS module feeling that this was the issue but we get the same code and symptoms.Also we can perform the ABS module coding and it accepts it until the key is cycled off then on at which time all the coding goes to 00000.I am now thinking instrument cluster.Any advice would be welcome.Thank you.
      Chris

      Auto scan included below;


      VCDS Version: Release 11.11.4 (x64)
      Data version: 20120807

      Tuesday,02,October,2012,14:06:50:26373

      Chassis Type: 8E - Audi A4 B6/B7
      Scan: 01 02 03 08 09 0F 11 15 16 17 18 36 37 45 46 55 56 57 65 67
      69 75 76 77

      VIN: WAULC68E23A310265 Mileage: 173900km/108056miles
      -------------------------------------------------------------------------------
      Address 01: Engine Labels: 06B-909-518-AMB.lbl
      Part No SW: 8E0 909 518 AF HW: 8E0 909 018 A
      Component: 1.8L R4/5VT G 0003
      Coding: 0016701
      Shop #: WSC 63351 000 00000
      VCID: 74EC692B14DC2AB835D

      No fault code found.
      Readiness: 0110 1101

      -------------------------------------------------------------------------------
      Address 03: ABS Brakes Labels: 8E0-614-517.lbl
      Part No: 8E0 614 517 H
      Component: ABS/ESP allrad 2328
      Coding: 04275
      Shop #: WSC 12345
      VCID: 2D5ABC4FE7763B70BA3

      2 Faults Found:
      00301 - ABS Return Flow Pump (V39)
      35-00 - -
      00283 - ABS Wheel Speed Sensor; Front Left (G47)
      30-00 - Open or Short to Plus

      -------------------------------------------------------------------------------
      Address 08: Auto HVAC Labels: 8E0-820-043.lbl
      Part No: 8E0 820 043 L
      Component: A4 Klimaautomat 1116
      Coding: 00000
      Shop #: WSC 63351
      VCID: 2A50B753D6982C485F1

      2 Faults Found:
      00710 - Defroster Flap Positioning Motor (V107)
      41-10 - Blocked or No Voltage - Intermittent
      01312 - Powertrain Data Bus
      79-00 - Please Check Fault Codes

      -------------------------------------------------------------------------------
      Address 09: Cent. Elect. Labels: 8E0-907-279-8E2.lbl
      Part No: 8E0 907 279 E
      Component: int. Lastmodul KAN 0305
      Coding: 00014
      Shop #: WSC 63351
      VCID: 346CA92B045C6AB8F5D

      1 Fault Found:
      01312 - Powertrain Data Bus
      79-00 - Please Check Fault Codes

      -------------------------------------------------------------------------------
      Address 15: Airbags Labels: 8E0-959-655-84.lbl
      Part No: 8E0 959 655 C
      Component: Airbag 8.4EP 2000
      Coding: 0010607
      Shop #: WSC 63351 000 00000
      VCID: 37769E27452A81A0D0F

      2 Faults Found:
      01221 - Crash Sensor Side Airbag; Driver Side (G179)
      012 - Electrical Fault in Circuit - MIL ON
      01222 - Crash Sensor Side Airbag; Passenger Side (G180)
      012 - Electrical Fault in Circuit - MIL ON

      -------------------------------------------------------------------------------
      Address 16: Steering wheel Labels: 8E0-953-549.lbl
      Part No: 8E0 953 549 N
      Component: Lenksáulenmodul 0308
      Coding: 00041
      Shop #: WSC 63351
      VCID: 3E788B033A10B0E8139

      No fault code found.

      -------------------------------------------------------------------------------
      Address 17: Instruments Labels: 8E0-920-9xx-8E2.lbl
      Part No: 8E0 920 900 L
      Component: KOMBI+WEGFAHRS. RB4 D36
      Coding: 03300
      Shop #: WSC 94708
      VCID: 2D5ABC4FE7763B70BA3
      WAULC68E23A310265 AUZ6Z0B0330291

      1 Fault Found:
      01316 - ABS Control Module
      49-10 - No Communications - Intermittent

      -------------------------------------------------------------------------------
      Address 46: Central Conv. Labels: 8E0-959-433-MAX.lbl
      Part No: 8E0 959 433 BB
      Component: Komfortgerát T7B 1311
      Coding: 11838
      Shop #: WSC 94842
      VCID: 72E06F333EC82488271

      Subsystem 1 - Part No: 8E1959801E
      Component: Tőrsteuer.FS BRM 0002

      Subsystem 2 - Part No: 8E1959802F
      Component: Tőrsteuer.BF BRM 0002

      Subsystem 3 - Part No: 8E0959801D
      Component: Tőrsteuer.HL BRM 0002

      Subsystem 4 - Part No: 8E0959802D
      Component: Tőrsteuer.HR BRM 0002

      No fault code found.

      -------------------------------------------------------------------------------
      Address 55: Xenon Range Labels: 4Z7-907-357.lbl
      Part No: 4Z7 907 357
      Component: dynamische LWR D09
      Coding: 00060
      Shop #: WSC 63351
      VCID: 040C39EB147C1A3805D

      1 Fault Found:
      00774 - Level Control System Sensor; Left Rear (G76)
      31-00 - Open or Short to Ground

      -------------------------------------------------------------------------------
      Address 56: Radio Labels: 8E0-035-1xx-56.lbl
      Part No: 8E0 035 195 F
      Component: symphony II NP2 0051
      Coding: 01001
      Shop #: WSC 94753
      VCID: 2A50B753D6982C485F1

      No fault code found.

      End ---------------------------------------------------------------------

      Results of second Autoscan after codes cleared;


      VCDS Version: Release 11.11.4 (x64)
      Data version: 20120807

      Tuesday,02,October,2012,14:21:43:26373

      Chassis Type: 8E - Audi A4 B6/B7
      Scan: 01 02 03 08 09 0F 11 15 16 17 18 36 37 45 46 55 56 57 65 67
      69 75 76 77

      VIN: WAULC68E23A310265 Mileage: 173900km/108056miles
      -------------------------------------------------------------------------------
      Address 01: Engine Labels: 06B-909-518-AMB.lbl
      Part No SW: 8E0 909 518 AF HW: 8E0 909 018 A
      Component: 1.8L R4/5VT G 0003
      Coding: 0016701
      Shop #: WSC 63351 000 00000
      VCID: 74EC692B14DC2AB835D

      No fault code found.
      Readiness: 0110 1101

      -------------------------------------------------------------------------------
      Address 03: ABS Brakes Labels: 8E0-614-517.lbl
      Part No: 8E0 614 517 H
      Component: ABS/ESP allrad 2328
      Coding: 04275
      Shop #: WSC 12345
      VCID: 2D5ABC4FE7763B70BA3

      2 Faults Found:
      00301 - ABS Return Flow Pump (V39)
      35-00 - -
      00283 - ABS Wheel Speed Sensor; Front Left (G47)
      30-00 - Open or Short to Plus

      -------------------------------------------------------------------------------
      Address 08: Auto HVAC Labels: 8E0-820-043.lbl
      Part No: 8E0 820 043 L
      Component: A4 Klimaautomat 1116
      Coding: 00000
      Shop #: WSC 63351
      VCID: 2A50B753D6982C485F1

      2 Faults Found:
      00710 - Defroster Flap Positioning Motor (V107)
      41-10 - Blocked or No Voltage - Intermittent
      01312 - Powertrain Data Bus
      79-00 - Please Check Fault Codes

      -------------------------------------------------------------------------------
      Address 09: Cent. Elect. Labels: 8E0-907-279-8E2.lbl
      Part No: 8E0 907 279 E
      Component: int. Lastmodul KAN 0305
      Coding: 00014
      Shop #: WSC 63351
      VCID: 346CA92B045C6AB8F5D

      1 Fault Found:
      01312 - Powertrain Data Bus
      79-00 - Please Check Fault Codes

      -------------------------------------------------------------------------------
      Address 15: Airbags Labels: 8E0-959-655-84.lbl
      Part No: 8E0 959 655 C
      Component: Airbag 8.4EP 2000
      Coding: 0010607
      Shop #: WSC 63351 000 00000
      VCID: 37769E27452A81A0D0F

      2 Faults Found:
      01221 - Crash Sensor Side Airbag; Driver Side (G179)
      012 - Electrical Fault in Circuit - MIL ON
      01222 - Crash Sensor Side Airbag; Passenger Side (G180)
      012 - Electrical Fault in Circuit - MIL ON

      -------------------------------------------------------------------------------
      Address 16: Steering wheel Labels: 8E0-953-549.lbl
      Part No: 8E0 953 549 N
      Component: Lenksáulenmodul 0308
      Coding: 00041
      Shop #: WSC 63351
      VCID: 3E788B033A10B0E8139

      No fault code found.

      -------------------------------------------------------------------------------
      Address 17: Instruments Labels: 8E0-920-9xx-8E2.lbl
      Part No: 8E0 920 900 L
      Component: KOMBI+WEGFAHRS. RB4 D36
      Coding: 03300
      Shop #: WSC 94708
      VCID: 2D5ABC4FE7763B70BA3
      WAULC68E23A310265 AUZ6Z0B0330291

      No fault code found.

      -------------------------------------------------------------------------------
      Address 46: Central Conv. Labels: 8E0-959-433-MAX.lbl
      Part No: 8E0 959 433 BB
      Component: Komfortgerát T7B 1311
      Coding: 11838
      Shop #: WSC 94842
      VCID: 72E06F333EC82488271

      Subsystem 1 - Part No: 8E1959801E
      Component: Tőrsteuer.FS BRM 0002

      Subsystem 2 - Part No: 8E1959802F
      Component: Tőrsteuer.BF BRM 0002

      Subsystem 3 - Part No: 8E0959801D
      Component: Tőrsteuer.HL BRM 0002

      Subsystem 4 - Part No: 8E0959802D
      Component: Tőrsteuer.HR BRM 0002

      No fault code found.

      -------------------------------------------------------------------------------
      Address 55: Xenon Range Labels: 4Z7-907-357.lbl
      Part No: 4Z7 907 357
      Component: dynamische LWR D09
      Coding: 00060
      Shop #: WSC 63351
      VCID: 040C39EB147C1A3805D

      2 Faults Found:
      01535 - Control Circuit for Right Headlight Range Adjusting Motor (V49)
      30-10 - Open or Short to Plus - Intermittent
      00774 - Level Control System Sensor; Left Rear (G76)
      31-00 - Open or Short to Ground

      -------------------------------------------------------------------------------
      Address 56: Radio Labels: 8E0-035-1xx-56.lbl
      Part No: 8E0 035 195 F
      Component: symphony II NP2 0051
      Coding: 01001
      Shop #: WSC 94753
      VCID: 2A50B753D6982C485F1

      No fault code found.

      End ---------------------------------------------------------------------

    2. n00b chrisqc's Avatar
      Join Date
      Aug 7th, 2008
      Location
      Montreal Quebec
      Posts
      7
      Vehicles
      1992 Saab 9000T,1997 audi A4 2.8l
      10-02-2012 05:47 PM #2
      I have an update to the above post.The speedo was working for about 15km then stopped.Fuel level when the car came in showed 3/4 full but now shows empty,it does not move at all.The measuring blocks show a combined value of a 3/4 full tank.Also the ABS programming has been successful,it showed up as correct after the last road test with no further input from us.
      Chris

    3. Forum Sponsor Dana @ Ross-Tech's Avatar
      Join Date
      Sep 15th, 2009
      Location
      Apollo, PA
      Posts
      2,907
      Vehicles
      02 Gti, 12 Tiggy SEL
      10-03-2012 08:52 AM #3
      False WSS faults can be caused by the incorrect ABS module but providing that fault didn't return, these Bosch 5.7 ABS modules require a 3 step coding process:

      http://wiki.ross-tech.com/wiki/index...28Bosch_5.7%29

      Were you completing the Login, Coding and G85 BS in that order within the same diagnostic session?

      In regards to the VSS try logging measuring blocks in several modules. I would start by checking the 01-Engine and 17-Instrument cluster but I haven't looked at a wiring diagram on this one yet and you may have VSS shown in several other modules.
      Dana Marie

      P.S. No Scan = No Soup

    4. n00b chrisqc's Avatar
      Join Date
      Aug 7th, 2008
      Location
      Montreal Quebec
      Posts
      7
      Vehicles
      1992 Saab 9000T,1997 audi A4 2.8l
      10-03-2012 10:25 AM #4
      Thank you for the reply Dana.Yes we followed the 3 step procedure and the coding is correct now. The code for; incorrect module coding has not returned.We have the same DTC with the old ABS module and the new ABS module for the left front abs sensor.We have the vehicle in today to pull the instrument cluster to see if there is anything obvious.Observations this morning;code for left front ABS sensor still there(will not clear), fuel level still shows empty(3/4 full),measuring block for speedo shows 361kph(car is stationary).

    5. 10-03-2012 01:08 PM #5
      That speedo condition usually exists when the cluster has been tampered with a very bad China tool for correcting odometer, or even just attempts to glitch read the eeprom.
      Jack Shapiro E.P.E. VAS>ASE Extern VST-3/1 LAB (TECH INQUIRIES ARE TO BE IN WRITING )
      7076062 NYS DMV SAE>NASTF>VW-Audi GEKO Authorized
      European Parts Emporium/Performance --- Immobilizer Solutions LLC --------
      Postadresse: 1001 State Route 17K Montgomery New York 12549 USA
      vwemporium@aol.com -845-457-9808 TEL 9AM-5PM --------TAKE CONTROL OF WHAT YOU OWN!!!!!!

    6. n00b chrisqc's Avatar
      Join Date
      Aug 7th, 2008
      Location
      Montreal Quebec
      Posts
      7
      Vehicles
      1992 Saab 9000T,1997 audi A4 2.8l
      10-03-2012 04:20 PM #6
      Hi Jack,thank you for the reply.Is there any way for me to check if the instrument cluster has been tampered with with VCDS?We removed the instrument cluster(no visible signs of anyone in there before)and checked all the pins,opened it up to look inside and saw no visible signs of trouble.We sprayed contact cleaner on pins and plug,cleaned off and plugged it all back together.Inside up on the lift everything worked;no codes for the left front abs sensor,speedo worked and fuel gauge reads 3/4 full.I took it on a road test and all was fine after 15 minutes,upon returning to the garage and bumping up onto the driveway in reverse there was a chime sound from the dash and ABS light came back on and when taken for a short drive the speedo is not working again.The same code for the left front ABS sensor is back.The customer needs the car so I will not have a chance to look at it again until next Tuesday.

    7. 10-03-2012 05:24 PM #7
      VCDS cant detect this issue unfortunately, or can physical visual inspection unless using a programmer to verify the actual data in editor with a valid compare image.

      This is usually a fault I see for the speedo, and gas gage, due to crap OBD burglar tools from China.

      What we could do, is look at the cluster for you. Maybe possibly fix it, or at least transfer all the keys and data needed to a new, re-man, or used unit from the dump.

      We have seen speedo heads just fail in this cluster unit.

      It got quiet. http://www.youtube.com/watch?v=K8E_zMLCRNg
      Last edited by Jack@European Parts; 10-04-2012 at 10:37 PM.
      Jack Shapiro E.P.E. VAS>ASE Extern VST-3/1 LAB (TECH INQUIRIES ARE TO BE IN WRITING )
      7076062 NYS DMV SAE>NASTF>VW-Audi GEKO Authorized
      European Parts Emporium/Performance --- Immobilizer Solutions LLC --------
      Postadresse: 1001 State Route 17K Montgomery New York 12549 USA
      vwemporium@aol.com -845-457-9808 TEL 9AM-5PM --------TAKE CONTROL OF WHAT YOU OWN!!!!!!

    8. n00b chrisqc's Avatar
      Join Date
      Aug 7th, 2008
      Location
      Montreal Quebec
      Posts
      7
      Vehicles
      1992 Saab 9000T,1997 audi A4 2.8l
      10-05-2012 01:10 PM #8
      I have an update to this car.The car is fixed.We did a wiggle and tap test on all components and harnesses with the VCDS hooked up and monitoring wheel speed.Only when lightly tapping the ABS module did the signal for the left front ABS sensor drop from 16kmh to 1kmh.We did this a number of times.It also set the same code for the sensor and the speedo stopped working.We reinstalled the new ABS module and after a few tries it accepted the coding.I drove it home last night and back in this morning (100km +) and had no problems.No ABS lights or codes and the speedo works. Thank you for all your help.We did notice that as long as the ABS sensor code was there the speedo did not work,clear the code the speedo would work.

    9. 10-05-2012 02:47 PM #9
      What about Mr. Gas gage?
      Jack Shapiro E.P.E. VAS>ASE Extern VST-3/1 LAB (TECH INQUIRIES ARE TO BE IN WRITING )
      7076062 NYS DMV SAE>NASTF>VW-Audi GEKO Authorized
      European Parts Emporium/Performance --- Immobilizer Solutions LLC --------
      Postadresse: 1001 State Route 17K Montgomery New York 12549 USA
      vwemporium@aol.com -845-457-9808 TEL 9AM-5PM --------TAKE CONTROL OF WHAT YOU OWN!!!!!!

    10. n00b chrisqc's Avatar
      Join Date
      Aug 7th, 2008
      Location
      Montreal Quebec
      Posts
      7
      Vehicles
      1992 Saab 9000T,1997 audi A4 2.8l
      10-07-2012 06:34 AM #10
      Sorry about that Jack,yes the gas gauge would drop out also.That is also back to normal.

    11. 10-07-2012 06:23 PM #11
      Cool,..... I thought so, just wanted to check.
      Jack Shapiro E.P.E. VAS>ASE Extern VST-3/1 LAB (TECH INQUIRIES ARE TO BE IN WRITING )
      7076062 NYS DMV SAE>NASTF>VW-Audi GEKO Authorized
      European Parts Emporium/Performance --- Immobilizer Solutions LLC --------
      Postadresse: 1001 State Route 17K Montgomery New York 12549 USA
      vwemporium@aol.com -845-457-9808 TEL 9AM-5PM --------TAKE CONTROL OF WHAT YOU OWN!!!!!!

    12. Junior Member
      Join Date
      Mar 4th, 2010
      Location
      Edmonton, AB
      Posts
      70
      Vehicles
      2004.5 GLI
      11-05-2012 11:38 AM #12
      hey..... i've been having issues with my cluster as well...
      very sporadic, and as you mentioned, when it works it'll only work for a short distance then cut out.
      this has been going on for over a year and haven't been able to figure it out.
      We replaced a bunch of sensors, even tried a new cluster.
      When the speedo stops working, the ABS light comes on and so does the traction control light.
      Everything else works including RPMs & gas.

      Think it could really be the ABS module? What should i do?

      The fault that keeps coming up is Speed Sensor "A" (Which i believe is front left wheel)

      Thanks!!

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •