Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 3 of 3

    Thread: 88 Fox Wagon Won't Turn Over - Battery is fully charged

    1. 10-03-2012 05:37 PM #1
      The wagon began to start roughly. Now, not at all. No power to the lights or radio. No clicks...nothing happens. I thought it was a dead battery, but i checked it and it has a full charge. Is their a fuse or a relay that would cause this? Or?

    2. Member
      Join Date
      Apr 16th, 2006
      Location
      Brokelyn, NY
      Posts
      4,958
      Vehicles
      90 fox, 85 gli
      10-03-2012 06:18 PM #2
      How did you check the battery? If nothing has power, check your leads from the battery. Ground goes to the battery tray and then between the block and tranny. Positive goes to starter and the electrical junction under the dash, driver's side. From the starter, there's another positive that goes to the alternator.

      There isn't a fusible link for everything that would blow.

      Chances are, the ground strap that connects to the battery is broken, or it's just another connection in the area / terminals not making good contact.
      I really suck at smog.

    3. 10-04-2012 12:52 AM #3
      Bad read on the battery! It was dead. Trickle charged it...it starts fine!

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •