Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 2 of 2

    Thread: 2004 Jetta GLI w/manual tranny weak acceleration

    1. 10-06-2012 11:42 AM #1
      Hey guys I have question about acceleration on '04 Jetta GLI w/6 speed transmittion. Doesn't mattery which gear I'm in it just so slow untill reving to about 3k RPM (when turbo kiks in). It is just really slow. Especially going up the hill (under load) I hear some whisling till about 3K rpms, then turbo kiks in and I hear loud intake sucking in. Wonder if that whisling noice is the recirculating noise from bypass valve.

      I have Weapon R short ram intake and front mount intercooler. Checked for leaks in the intercooler loop and everything seems to be ok. Recently changed my spark plugs and washed intake filter. Wonder in MAF sensor is going bad, or maybe so mething wrong with the temp sensor in the intake manifold. When I checked my intake temp with the software it was showing kind of hot. Wonder if its worth changing those MAF and Air Temp sensors. However, there's no check engine lights.

      Would like to hear your opinions on this matter, or maybe somebody came accross this issue before. Your comments would be greatly appreciated. Thanks in advance.

    2. Junior Member
      Join Date
      Dec 22nd, 2008
      Posts
      61
      Vehicles
      2002 GTI 24v VR6
      10-11-2012 07:21 PM #2
      I had similar problem when my crank case vent was leaking. Repaired leak it was all good. Check the pcv system for cracked plastic hosing.

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •