Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 6 of 6

    Thread: Need help with my heater

    1. 03-01-2015 05:54 PM #1
      I have a 99 jetta wagon 1,9 TDI. I had problem with a coolant-leak. Since it was time for a timing-belt change, I changed waterpump, thermostat, temp-sensor, heater-core and checking blend-doors. So all that is new and fixed. I've flushed radiator, heater-core several times. First i suspected the thermostat not to open properly, so I bought a new OEM one. Have good flow and no leaks, but there isnt comming any heat in my heater. After the engine is properly warm (90celsius) if I increase RPM I get a little warmth(Very little) but is disappear Very quickly when I turn up the fan.

      any good tips?

    2. Yesterday 04:24 AM #2
      My car overheated today. I stopped it at 100degrees c. And both fans on radiator was on. Lower radiatorhose was cold. And i hose from heater core was cold. So I have a flow problem. Checked waterpump again. It is ok. What more can stop the flow? Radiator-flow is ok, heatercore-flow is ok.

    3. Member mk4vrsix03's Avatar
      Join Date
      Mar 7th, 2004
      Location
      Rancho Cucamonga, CA
      Posts
      2,082
      Vehicles
      '03 GTI VR6, '14 Golf
      Yesterday 10:43 AM #3
      Air lock in the system perhaps? Are you losing coolant?

    4. Yesterday 12:22 PM #4
      Not loosing any coolant while driving, but when the engine was cold again today the coolant-tank was empty. I topped it(to the mark) and drive home, and then i had to fill up 0.2 litres again. But now the heater isnt dead cold longer, just no heat. So a slightly differense. I suspect air-locks too, but how hard can it be to get them out?


      Sent from my iPhone using Tapatalk

    5. Yesterday 12:23 PM #5
      Coolant-tank was full(Max mark) when it was hot.


      Sent from my iPhone using Tapatalk

    6. Member mk4vrsix03's Avatar
      Join Date
      Mar 7th, 2004
      Location
      Rancho Cucamonga, CA
      Posts
      2,082
      Vehicles
      '03 GTI VR6, '14 Golf
      Yesterday 12:31 PM #6
      So you are losing coolant if you are having to add coolant. Pressure test the system.

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •