VWVortex.com - Repair Snow performance controller. Anyone ever try it?
Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 3 of 3

    Thread: Repair Snow performance controller. Anyone ever try it?

    1. Member PerkeyTurkey's Avatar
      Join Date
      Dec 3rd, 2007
      Posts
      1,403
      Vehicles
      84 Rabbit
      10-23-2018 08:59 PM #1
      Hey so I recently purchased a car with an old snow performance kit that wasn’t working. I narrowed it down to a faulty controller. I contacted snow for a possible repair, but they told me it was too old and they no longer carry parts for my controller (Vm-20). I really don’t want to purchase another controller. Anyone ever pull one of these apart and successfully repair one? Anyone have advice? I was thinking about taking it to a computer repair shop and have them take a crack out of it. Any help would be greatly appreciated!

      Steve

    2. Remove Advertisements

      Advertisements
       

    3. Member PerkeyTurkey's Avatar
      Join Date
      Dec 3rd, 2007
      Posts
      1,403
      Vehicles
      84 Rabbit
      10-30-2018 02:41 PM #2
      Bump

    4. Member dlsolo's Avatar
      Join Date
      Sep 5th, 2004
      Location
      Sanford, NC
      Posts
      1,731
      Vehicles
      2004.5 PG VW Jetta GLI
      09-18-2019 12:25 PM #3
      Quote Originally Posted by PerkeyTurkey View Post
      Hey so I recently purchased a car with an old snow performance kit that wasn’t working. I narrowed it down to a faulty controller. I contacted snow for a possible repair, but they told me it was too old and they no longer carry parts for my controller (Vm-20). I really don’t want to purchase another controller. Anyone ever pull one of these apart and successfully repair one? Anyone have advice? I was thinking about taking it to a computer repair shop and have them take a crack out of it. Any help would be greatly appreciated!

      Steve
      Did you ever get this resolved? I'm having the same issue.
      She ain't stock!

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    vwvortex.com is an independent Volkswagen enthusiast website owned and operated by VerticalScope Inc. Content on vwvortex.com is generated by its users. vwvortex.com is not in any way affiliated with Volkswagen AG.