VWVortex.com - Possible turbo issues
Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 3 of 3

    Thread: Possible turbo issues

    1. Junior Member KingMK's Avatar
      Join Date
      Jul 16th, 2014
      Location
      New York
      Posts
      90
      Vehicles
      2015 MK7 GTI S, 2005 MK4 Golf GLS
      06-08-2019 08:04 PM #1
      Hey guys, I have a base model '15 GTI with around 52k miles on it. Typically when I'm pushing the car around 2k to 4.5k I can hear the turbo spooling (for give me if my # range is incorrect) but for the last few days 1. I dont hear it spool 2. I dont feel it pulling as much and 3. It feels slower when I hit the pedal. Maybe it's in my head but am I crazy to think my turbo might be going? I can just feel the car isn't moving the same anynore.

      Sent from my SM-G960U1 using Tapatalk
      G O L F

    2. Remove Advertisements

      Advertisements
       

    3. 08-15-2019 10:12 AM #2
      Quote Originally Posted by KingMK View Post
      Hey guys, I have a base model '15 GTI with around 52k miles on it. Typically when I'm pushing the car around 2k to 4.5k I can hear the turbo spooling (for give me if my # range is incorrect) but for the last few days 1. I dont hear it spool 2. I dont feel it pulling as much and 3. It feels slower when I hit the pedal. Maybe it's in my head but am I crazy to think my turbo might be going? I can just feel the car isn't moving the same anynore.

      Sent from my SM-G960U1 using Tapatalk
      Typically, you would also start to hear a more refined noise when your turbo goes out. On shut down or decel, it would start to sound like a dentist drill.

      I would say that you probably have a boost leak somewhere in TBB, IM, or inlet piping. IF you had a boost leak off of the exhaust manifold you would hear a lot more noise than your normal running condition

    4. 08-15-2019 02:14 PM #3
      Quote Originally Posted by KingMK View Post
      Hey guys, I have a base model '15 GTI with around 52k miles on it. Typically when I'm pushing the car around 2k to 4.5k I can hear the turbo spooling (for give me if my # range is incorrect) but for the last few days 1. I dont hear it spool 2. I dont feel it pulling as much and 3. It feels slower when I hit the pedal. Maybe it's in my head but am I crazy to think my turbo might be going? I can just feel the car isn't moving the same anynore.

      Sent from my SM-G960U1 using Tapatalk
      Check for boost leaks in your piping, manifolds, and your TBB

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •