VWVortex.com - 2012 Sportwagen Rear Door Electrical Issue
Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 3 of 3

    Thread: 2012 Sportwagen Rear Door Electrical Issue

    1. 09-11-2019 06:44 PM #1
      I have a 2012 TDI sportwagen, 73k miles, all maintenance done up to date, Kerma TDI tune, Polar FIS module and other small upgrades.....now to the problem, nothing on the rear driver side door works. Well to be fair the speakers work, but the window doesn't, the lock doesn't, the door open switch doesn't, the lock switch doesn't light up...

      Thankfully the window is in the up position (gotta look for the silver lining!) the window switch on the door or on the drivers door does nothing (I don't hear the motor even try to move). The door also does not lock, either when the switch at the door itself is pressed, the driver side lock switch, or the key fob, nothing happens on that door. When I open the door the interior lights do not turn on and the dash screen doesn't indicate that the door is open. The lock/unlock switch does not light up. The speakers (both on the door) however DO work.

      This led me to believe that it was a power issue.... no power to the door, something was wrong with a fuse or the cable or wire run to the door. If it was a fuse it would have been a global problem it seems, so crossed that off the list (I still took a look at all the fuses just to be safe, all fine). So I took the boot back and checked on the wiring at the door hinge everything looks fine, no degradation in any insulation, no cracking, no burn areas, no arcing noticed. I then took the door panel off and checked the power at the main door module connector, there's power! (Not what I expected, but ok...)

      So I thought my problem was that module. I removed it and the window motor and just for fun I took the module off of the motor itself. I put 12 volts to the window motor in both directions and it works perfectly.... so has to be the module right?

      Wrong I ordered a new module/window motor since they only come as one piece. Went and installed it today and still the problem persists.

      Any ideas? I've search a couple of different forums, done countless google searches, youtube vids, consulted 2 friends who also work on their VWs and all are at a loss. I'm about to bring it to the dealership but I really don't want to admit defeat, lol. Help? Please? Anyone? Lol.

    2. Remove Advertisements

      Advertisements
       

    3. Member JaxPlanet's Avatar
      Join Date
      Sep 17th, 2018
      Posts
      107
      Vehicles
      2012 JSW 2.5
      09-12-2019 11:00 AM #2
      FWIW: Your JSW is a Golf MK6 variant. I recommend that you search the Golf MK6 forum and repost there, if necessary. This forum mostly focuses on features unique to the JSW, like everything behind the rear doors and cosmetics.

    4. 09-12-2019 06:06 PM #3
      Quote Originally Posted by JaxPlanet View Post
      FWIW: Your JSW is a Golf MK6 variant. I recommend that you search the Golf MK6 forum and repost there, if necessary. This forum mostly focuses on features unique to the JSW, like everything behind the rear doors and cosmetics.

      Sorry, I saw the description of this forum and assumed it's for my car (2012 Sportwagen), I'll post elsewhere as well. Thanks!
      "Forum: Jetta SportWagen
      Discussion forum for the Jetta SportWagen produced from 2009 to 2014. Also known as Golf Wagon and Golf Estate in non-US markets."

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •