VWVortex.com - Rear wiper not working properly - any ideas on the fix?
Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 3 of 3

    Thread: Rear wiper not working properly - any ideas on the fix?

    1. Junior Member
      Join Date
      Feb 27th, 2013
      Posts
      40
      Vehicles
      2012 Routan SE w/ RSE & Nav
      09-18-2019 04:04 PM #1
      The rear wiper blade on my 2012 Routan is not making good contact with the glass. It turns on and acts like it's wiping, but doesn't actually clear the glass. I have tried four or five different brands/styles of wiper blade and none of them make any difference. It's like there is no wiper blade at all. If I push the blade down towards the glass with my hand while it is wiping, it makes stronger contact and clears the glass.

      Any ideas on what the fix is? Is the spring in the wiper arm supposed to be pushing the blade towards the glass? It doesn't seem to offer much resistance when I pull up on the arm. Maybe I need to replace it?

    2. Remove Advertisements

      Advertisements
       

    3. 09-18-2019 04:25 PM #2
      Quote Originally Posted by CDJackson View Post
      The rear wiper blade on my 2012 Routan is not making good contact with the glass. It turns on and acts like it's wiping, but doesn't actually clear the glass. I have tried four or five different brands/styles of wiper blade and none of them make any difference. It's like there is no wiper blade at all. If I push the blade down towards the glass with my hand while it is wiping, it makes stronger contact and clears the glass.

      Any ideas on what the fix is? Is the spring in the wiper arm supposed to be pushing the blade towards the glass? It doesn't seem to offer much resistance when I pull up on the arm. Maybe I need to replace it?
      Chances are the hinge is binding due to corrosion, you can try spraying oil into the hinge and working it back and forth to loosen it up.

    4. Junior Member
      Join Date
      Feb 27th, 2013
      Posts
      40
      Vehicles
      2012 Routan SE w/ RSE & Nav
      09-18-2019 04:29 PM #3
      I will give that a try, thanks!

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •