VWVortex.com - Vw gti rns510 radio issue. Power cycle, display blanks off.
Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    VWVortex


    Results 1 to 2 of 2

    Thread: Vw gti rns510 radio issue. Power cycle, display blanks off.

    1. 01-29-2020 12:21 PM #1
      Hello my fellow techies out there.
      I am new to this platform and hoping i can find an answer to issue i have with this rns510 nav/radio device.
      Unit was a problem from prevoius owner and now my problem. It keeps powering down or loosing power to display and selective pushbuttons.
      Prevoius owner tried software upgrade, with no such luck.
      It seems to me like a internal power supply issue or hard drive failing to boot up?
      I am lloking for some feedback on possible repairs or tips on diagnosing problem.
      Unit is currently removed from car and on bench for a visual inspection of internal parts.
      Any help or similar model issue, please advise.
      Thank you
      gs1125

    2. Remove Advertisements

      Advertisements
       

    3. 02-11-2020 11:23 AM #2
      I have recently(past 3 weeks) been experiencing the same issue with my RNS510; HW: H65; SW: 3696 in a 2013 Passat. The radio will be on satellite(Sirius/XM) and the unit will go on mute, then reset. It happens twice on a 30 minute commute. No noticeable patterns to the reset.

      Has anyone experienced recent resets on their units as well?

      Best Regards,

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    vwvortex.com is an independent Volkswagen enthusiast website owned and operated by VerticalScope Inc. Content on vwvortex.com is generated by its users. vwvortex.com is not in any way affiliated with Volkswagen AG.